Totally disable ipv6


I want to totally disable ipv6 in my Home Assistant (hassio through VM)

I disabled ipv6 in settings (system/network/ipv6/disabled) but HA is still using ipv6 on my network interface (enp0s3)

I disabled ipv6 on enp0s3 through SSH using nmcli command :

nmcli connection modify Supervisor\ enp0s3 ipv6.method “disabled”

It works, it disable ipv6 but… if I restart my VM ipv6 is back again

Do you have any idea to totally disable it ?

Many thanks !


That is exactly the same problem I have currently. My HA drops from cloud every day.
Any new information how to fix this?

  • Jarmo

I played around some, but ended up only re-confirming your findings.
I did a test using the nmcli command you mentioned, and I looked inside
/etc/NetworkManager/system-connections/Supervisor\ enp0s3.nmconnection and it shows the ipv6 entries:


But after a reboot, the method changed to link-local.
I don’t really know why. AFAIK a modify on a connection profile is suppose to persist.

+1 to this issue here. My HA drops out every 40 minutes or so. Today I can’t connect at all.

Was fix or work around found?

Would be interested to know this too.

The only thing I can suggest is seeing if you can disable IPv6 on whatever you’re using for a router, if it supports that.

Also, if you’re on a Supervised version of Home Assistant, you can got to settings/config/network and disable IPv6 in there.

You can’t disable IPV6 on some router and… unfortunately that’s my case :slight_smile:

Like I said in original post, IPV6 is already disabled in settings (settings/config/network) but it doesn’t seem to really disable it

This command did the job.

nmcli connection modify <connection_name> ipv6.method ignore

To check if ipv6 is permanently disabled you can

cat /etc/NetworkManager/system-connections/<connection_name>

There you should find method=ignore

This won’t survive a reboot either.

Did anyone find a permanent solution?