Totally hangs (Raspberry PI3A+) from 2023.11.. is it only me?

It did happen 2 times in 2 days, from when updated to ver 2023.11.1
Considering that it did never happen before … I suppose that latest version has something wrong causing the issue…
Until now the WatchDog did always do his job… so when there was some problem the system was restarting itself… but now it’s not working
I know that without a deep analysis (and logs) it’s impossible for anyone to understand the issue (unless some logs are automatically uploaded to developers)… but I wonder if someone else here is experiencing the same?

Given the RPi3A+ only has 512Mb of RAM, I’m a little surprised it worked at all before!

HASOS has a realistic minimum requirement of 1Gb of RAM, and really needs 2Gb+. Running on a RPi3A+ likely involved a lot of swapping memory to disk, which will burn a hole in your uSD storage. My HAOS installs with several add-ons sit at 1.1 GB memory used.

The HASS installation instructions should be more specific than “Raspberry Pi 3 is ok too” as the RPi3a a different beast from the RPi3b.

I’d revert to the previous version that worked, take a FULL backup, download the backup, and look to upgrade the hardware.

1 Like

Sorry but I am the proof that it can run with no problem also on Raspberry PI3A+ with 512Mb of Ram… as it is running from over ONE YEAR with no problem…
Of course I had to fine tune to have it running properly, eg using/configuring a swap file of 1GBytes (used for about 30%)… and not abusing with plugin/addon

The fact that only after the latest update the problem started means that:

  • the Watchdog is not working anymore properly (as it was working before)
  • something else introduced by latest update is creating some problem

Anyway I don’t want to argument about that (as said without logs and a deep analysis nobody can understand the real reason) or about the proper HW to run HA… my post was just to ask to others (with same or similar HW) if they are experiencing the same problem…

For me this is the 1st time I have this problem from over 1 Year


Chapeau to you for hand-tuning a HASS install onto a RPi3a+! :mage:t2:

As there are barriers to running on a RPi3a+, you might struggle to get many other people with direct experience.

I’ve got a small HAOS install running fine in production on a RPi3b+ with the latest OS and HASS so the later hardware does seem to be supported fine.

There could be hardware driver changes between a kernel compiled for a RPi3b and a RPi3a, and the memory limit might have driven updated assumptions (similar to Linux distros removing i386). HAOS is based on so I’d suggest a look in the HASS developer docs, and recent GitHub commits to see if there’s any changes. Failing that, the obvious step is file an issue.

If you suspect hardware, a RPiOS uSD card can be a useful stress test with more accessible logging.

Thanks for your comments…

For now I will continue to monitor the situation…
Maybe it was just a case that my “poor” raspberry did hang 2 times in few days for the 1st time after over 1 year of perfect working…

FYI that’s the typical resource utilization of my PI3A+

1 Like

Since HA is constantly evolving and your aging rPi 3A is, well, aging it’s possible that updates may add functionality that surpasses your pi’s ability to function properly. If it continues you could try downgrading to a previous version to see if things stabilize.

I’m sure we’ll have similar topics in a year or two when rPi 4B is the “old clunker” that people are having crash :grimacing:.

I hope that “evolving” doesn’t mean that it will always increase resource consumption…
Developers should also focus on “optimizing” the code… and not only “adding” code
But I know that this just “theory…”…

Sometimes, though, evolution includes improvements in hardware to the exclusion of what may be considered obsolete or less likely to be implemented on new installations, like an rPi 3A. With better processor power, better routing and more memory comes the ability for HA to do something it could not before (i.e., adding Bluetooth or BLE). You are right, backwards compatibility should always be considered but there’s a fine line between becoming stale and requiring the latest possible hardware.

That’s why the HW IT market is always flourishing… people need to change HW faster because SW is always more and more resource hungry

I do have (I think, if not let me know :wink:) same kind of issue.
My RPI3 crashes about once a day.And with crashing I mean, shutdown.
Only thing to get it startup again is removing power and put it back on again.
Have been trying to find something in the logfiles, but until now, no luck.
Desperately looking for a solution.

That is pretty much the worst thing you can do to an SD card and will kill even the best quality ones sooner or later. Don’t do that.

I am using Samsung MB-MJ32KA PRO Endurance

Sounds like the wrong card for that task indeeed. This card is designed for contiouns sequential writes like video recording. In such a scenario no write amplification happens and the flash should therfor last quite long.

What you are doing with DB recording and swapping are small random writes which will cause significant write amplification and wear the flash much faster.

Swapping on flash isn’t a good idea - better might be (ab)using CPU cycles instead (zswap?).

Regarding a good cards for fast random i/o operation you want to use some with a A1/A2 label like mentioned in the docs.

Thanks for your comments/suggestions…
For now I have to say that - except the single (well 2 times really) event of totally hangs (watchdog didn’t work) - I don’t have big issues… and it is running from over one year…
One issue (recurrent from quite long time) is the following Home Assistant automatic restart for API call error? - Installation / Home Assistant OS - Home Assistant Community (
and it cause system restart every day or so… but this also appears to happen to other people… not only to me.
But as said my HA setup is not abusing of fancy plugins/addons…
My DB is about 350Mb (stable size)…
WIll see how will it continue to work

Did you buy it on Amazon ? If yes, then it’s almost guaranteed to be a fake (with considerably lower specs). It’s pretty much impossible nowadays to buy an original brand SD card on Amazon or Ebay.

Even those will wear out really fast when used as swap. There are so many write ops on a swap drive (especially when used heavily with so little RAM) that even the best wear leveling cards with tons of headroom (and with 32GB the headroom is really really small) will be killed really quickly.

Correct. That’s why you can read in my post the following line

Come on… it’s original 100%… I know for sure, believe me…

It seems that many people doesn’t want to accept/believe that HA can run properly on Raspberry PI3A+ on SD card…
Sorry but I am the proof that it can!

1 Like


Totally hangs (Raspberry PI3A+) from 2023.11… is it only me?

You are one of them

In fact the post was for getting feedback from others Raspberry PI3A+ users… not to get critics from NON-Raspberry PI3A+ users…
Anyway… the problem of totally hangs just happened 2 times (in over one Year)… so I can consider anyway this a good results… isn’t it?

I think that at this point the discussion can be closed