TP-Link: How to set up?

Hi, I bought a TP-Link Tape P115 smart plug with energy meter function.

I downloaded the Tapo App on my phone and connected the plug to the wifi. The the firmware was updated.

In HA I wanted to integrate this plug via the integration. When I click on the Integration via Menu I have to insert a Host address. I tried the IPs of: router, repeater, plug, HA. No device was found. Even when I let it empty.

So I tried to use configuration.yaml:

  discovery: false
    - host:  #kueche

(Code was found in this topic, so I adapted).

What do I have to do to set it up correctly?
In the documentation to the integration, I can not find any hint to it.

Thanks for helping!

Try the hacs tapo intergation…what you a referring to is kasa…which this device is not

Where can I find this Integration? It is Not in the integration List

? for me it is …

1 Like

It will appear in the HACS integrations list you can install, once you have installed the HACS integration (see the page) on your HA system. Sorry my colleague neglected to point out that was a HACS integration.

1 Like

?? see my comment… “hacs tapo integration”

Thanks a lot.
After getting HACS it was very easy.
HACS - Setup

So I read it is working now? If so then please mark one of my posts for ‘solution’ (one of the icons… if available…sometimes it is not)

added to that, HACS has plenty of nice things, not just integrations but very cool lovelace/card (tricks) too

I already did.

Can you describe how to usw the Energy Meter Sensors of the P115. On/Off is already working, But I do Not have the entities of the Energy Meter.

There were some issues with the firmware… have a look here.
From other brand plugs, sometimes it was waiting, sometimes delete and setup again, sometimes activation via their native app
If it does not help to get it to work, then you should open a ticket
Issues · petretiandrea/home-assistant-tapo-p100 (

If you noticed, OP asked “Where can I find this Integration? It is Not in the integration List” — because for a newcomer, saying “hacs tapo” is basically jargon / gibberish, and you have to explain he needs to install HACS before that makes any sense.

This is the last word I will spend on this, the user is there since Feb 21…this is not new…hence. Please donot answer anymore, topic closed.