TP-Link Kasa HS200 Switches Not Discoverable

I’m encountering a strange issue trying to add some new Kasa / TP-Link HS200 switches to my Home Assistant configuration. I am no stranger to Kasa/TP-Link products have successfully integrated 40+ Kasa devices into HA.

Here are the details:

  • Currently running HA v2023.7.3 as a VM on Unraid (v6.12.3)
  • I added 3 new HS200-BL Kasa switches and connected them to my usual IoT VLAN’ed wireless network.
  • I have assigned static IPs (and also tried with dynamic IPs assigned by my Unifi router)
  • I have added the IP addresses into my config.yaml (same as I’ve done with the other 40+ Kasa devices)
  • I have restarted HA multiple times
  • I have restarted the entire network multiple times
  • I have restarted Unraid
  • I have power-cycled the switches

I can see and activate the switches directly within the Kasa / TP-Link app (as well as Smartthings - which I do NOT have integrated with HA)

When I try to auto-discover the new devices, they are not found. When I try to manually enter the IP address, they are still not found.

I don’t think that I’m doing anything differently than I had before with all of my other Kasa switches.

Any advice or troubleshooting that I should review?

Screenshot of how I’ve previously setup the “host” IPs within the config.yaml:

I am bit confused… HS200 switches are Homeseer Zwave. As far as the Kasa-TPLink switches, do they show in your Kasa App ?

The HS200 is the single-pole wifi Kasa/TP-Link switch: [](https://Kasa HS200).

Yes, I can see (and control) these switches from the Kasa app.

Are you using this TP Link integration?

Sure am:

Have you tried:
(1) Reboot your HA box
(2) Delete the integration and re-installing it

I have rebooted my HA box several times (it’s a VM in Unraid).

If I delete the integration, will I lose all of my existing devices/entities/configs?

I appreciate your advice!

You may have to update your automations.

Update - I just tried adding a new HS200 (not the HS200-BL) and it added perfectly to my Home Assistant. Something is definitely different about the HS200-BL (the “-BL” is for the black switch).

Per the user manual, there is a different setup/initialization procedure for the HS200-BL which seems to connect to the switch via Bluetooth (?) first and then assigns the wifi credentials.

Still - my Unifi router sees the HS200-BL switch just like it does all of my other HS200 (non “-BL”) switches. It’s on a 2.4GHZ IOT network with a static IP.