TP-Link Kasa slow after 2021.8.2 and HA non responsive

Hello. I have 36 devices 51 entities in my TP-Link Smart Home integration. This has worked great as I have many smart switches and plugs throughout my house and the response from pressing the button in HA to the switch is instant.

After the upgrade to 2021.8.2 I have 36 devices (same) and 171 entities (120 more). Most of these new entities are the energy sensors that I don’t really use as I am currently using Sense (and the Sense integration) for my energy monitoring.

Unfortunately, now my HA is unresponsive most of the time and very sluggish. To get to my Lovelace or other areas such as Supervisor or Integrations it can take over 20 seconds and to switch a plug or switch it can also take upwards of 30 seconds or more if it responds. The HA restarts many times on its own. I have tried to disable the new 120 entities which helps but it is still not like it was.

Also, if I disable the TP-Link integration HA is very responsive (running in a VM on my windows machine).

I don’t know what to do other than going back to 2021.7.4 but I am worried that I will be stuck there. Any ideas?

1 Like

did you read this:

Yes I have. and the local still works for me on 2021.7.4. I would love to go to another platform but have already spend hundreds on this one as literally most of my switches in my house are those switches. I originally liked them because of local and no hub (directly connect to power and to the wifi).

I know that it is working local in 2021.8.2 as well because I can disconnect it from the internet and it still does turn off the switches… just takes longer.

And HA as a whole is sluggish not just them, unless I disable the integration then HA is snappy.
That is why i originally disabled all 120 new sensor entities that popped up in the 2021.8.2 release. and it has helped… but still not as fast as I am used to even within other areas of HA outside of anything TP-Link.

I’m in the same boat - just about as many Kasa devices, everything is super slow after upgrading to 2021.8.

Well at least I know I’m not alone… I am wondering if it’s all the new sensors that came in 2021.8 and how they handle the sensors . I’ve also noticed that my sensor graphs that are not Kasa are all so slow to load.

The integration uses a DataUpdateCoordinator since 2021.8 to be able to share data between different entities. Because of this, major changes were made to the integration but these shouldn’t slow down your installation. The integration does not make more request than before. If this problem persists, please open an issue in the core repository and provide debug logs, to do so add the following to your configuration.yaml:

  default: info
    homeassistant.components.tplink: debug 
    pyHS100: debug

I use the TP-Link integration in Home Assistant Core and Home Assistant Container but have not encountered any problems. Does your VM have enough processing power and memory?

1 Like

I noticed a similar slowdown when I added the SmartThings integration back when i was in version 2021.6. It brought 109 entities. After a couple days, it was back to being super fast again. No idea why it slowed down, but it resolved itself. Might just need a day or 2 to resolve itself.

Ok so I have done some other testing.

The Setup:
My host machine has a AMD 3700X, 32 GB RAM, and a m.2 NVME SSD. Each VM has up to 8gb ram and 4 cores (yes overkill but wanted to make sure it wasn’t resources).
I have also done the same test on a Raspberry Pi 4 8GB with the same results.

The Test:
start with a clean instance of HAOS 2021.8.3
Install File Editor addon
Install MariaDB ( I like this for DB, although I have also tried it without and same result)
restart HA
edit configuration.yaml and add the logger
restart HA
install the TP-Link Integration
HA looks for devices and finishes configuration
System starts to slow - which i guess makes sense as it is adding all the sensors
restart system
see if all TPLink devices come back and connect, if not restart.

system can then become unresponsive and can randomly restart

after a few restarts it now fails to setup the integration. and the system runs fas as the integration is not enabled (did not have this issue with 2021.8.2 )

so I guess the next step is to open a ticket unless anyone has any ideas.

Has anyone else had the failed to setup come up in 2021.8.3?

Thank for filing an issue on GitHub, @starfleet_k. I’m also seeing this behavior and I’ve added my data there: TP-Link Kasa slow after 2021.8 and HA non responsive · Issue #54234 · home-assistant/core · GitHub

You are Welcome, thanks for adding your data as well.

I’m a brand new Home Assistant (3 days in) user making the switch from a lifelong SmartThings user. I spend two days moving 54 z-wave devices and 35 Zigbee devices only to have the system go from “this is the most amazing thing” to downright awful unusable in a matter of a day. CPU was fine (on a Pi4 4GB of memory). I started dropping down every integration I could, including hours of logging and troubleshooting, almost to the point of rebuilding onto new faster hardware. Everything from the UI to automation felt lethargic and dismal. Until I disabled the TP-Link integration, and it was like I had a brand new Home Assistant again. I’m not getting rid of my 3 HS300 and 3 KP115 as they all work great locally (I am monitoring them with my own Grafana/InfluxDB collector.) I’ll follow along with the opened issue list here in earnest… Thanks for sharing your issue here to save me from insanity and rebuilding new hardware.

This alert is highly misleading. The linked TP-Link FAQ even says ‘only applies to UK’. I can’t speak for other countries but I have 12 or so of the KP115 plugs in Australia (ones with energy meter), I have updated the firmware in the app, and they definitely all still have local access available.

I have been following this thread for a while. It is the main reason I haven’t upgraded and stayed on 2021.7.4. I have 2 HS100 & 2 Hs110 (Plus 2 LB100 Globes)
I see that the github issue is still open, but it appears to be working now.
So my question is can I update to the latest version of core without this issue occuring.

Thanks all…