TP-Link Smart Home: Local Pooling / Scan Internval Issue

Hello, I’m trying to set up a quick automation when the TP-link switch (HS220) is physically pressed it turn on a Phillips Hue light.

Problem is: since it is local pooling, it takes 30 seconds for HA to see a change and trigger my automation.

Any suggestion on how to fix this issue?

I’ve tried manually setting the scan_interval (scan_interval: 10) or interval_seconds (interval_seconds: 5) without success.

I appreciate any help.

Automation code for reference:

- id: '15637307403XX'
  alias: Bedroom (Switch ON)
  - entity_id: light.bedroom_switch
    platform: state
    to: 'on'
  condition: []
  - entity_id: light.hue_bedroom
    service: light.turn_on