Traccar/HASSIO Device Tracker Issue: Send failed (VPN?)


I am trying to get Traccar on Hassio working with a Traccar Client running on my smartphone.
Hassio is running as a docker instance on my QNAP device on my home network which is behind a VPN. I have duckdns configured to allow outside communications in (such as Google Assistant) and my firewall forwards the 8123 port and 8082 port.
The Traccar server does shows Status Offline for my device and the log on my smartphone also says “send failed”. I can connect with my device to a traccar demo server.

I use the Traccar addon and it is configured as follows:

ssl: false
certfile: fullchain.pem
keyfile: privkey.pem
log_level: debug

My configuration.yaml is as follows:

  - platform: traccar
    port: 8082
    username: <NAME>
    password: <PASSWORD>

My smartphone Traccar Client is configured as follows:

Device ID: <DEVICE_ID>
Server_URL:  http://<DUCKDNS>.org:8082

Naturally, I have added the above device ID to the Traccar Server through the webpage in my hassio instance.

Can you help me out?

Hi Kalenden, I’m working on that too.

You shoud go in Settings => Integrations. Then, click on the plus sign and search traccar.

That should give you the weebhook you should use as Server URL in you phone.

Hope it helps.