Tradfri bulb not working


I recently bought a new IKEA Trådfri bulb and added it to my Zigbee network. I already have some IKEA bulbs working correctly, but this one I can’t get to work. It is recognized correctly, and an Entity with the right controls is created. However, the bulb does not react on any command.

Does someone have an idea how to solve this? Or can it be a faulty bulb? In the latter case I can try to exchange it for another one at the IKEA store.

This is the device signature:

  "node_descriptor": "NodeDescriptor(logical_type=<LogicalType.Router: 1>, complex_descriptor_available=0, user_descriptor_available=0, reserved=0, aps_flags=0, frequency_band=<FrequencyBand.Freq2400MHz: 8>, mac_capability_flags=<MACCapabilityFlags.AllocateAddress|RxOnWhenIdle|MainsPowered|FullFunctionDevice: 142>, manufacturer_code=4476, maximum_buffer_size=82, maximum_incoming_transfer_size=82, server_mask=11264, maximum_outgoing_transfer_size=82, descriptor_capability_field=<DescriptorCapability.NONE: 0>, *allocate_address=True, *is_alternate_pan_coordinator=False, *is_coordinator=False, *is_end_device=False, *is_full_function_device=True, *is_mains_powered=True, *is_receiver_on_when_idle=True, *is_router=True, *is_security_capable=False)",
  "endpoints": {
    "1": {
      "profile_id": 260,
      "device_type": "0x010c",
      "in_clusters": [
      "out_clusters": [
    "242": {
      "profile_id": 41440,
      "device_type": "0x0061",
      "in_clusters": [
      "out_clusters": [
  "manufacturer": "IKEA of Sweden",
  "model": "TRADFRIbulbE27WSglobeopal1055lm",
  "class": "zigpy.device.Device"

Whenever I try to change the state of the bulb, by using the HA UI, I get an error like this in te logs:

2022-01-02 15:08:19 DEBUG (MainThread) [zigpy.device] [0x18f2] Delivery error for seq # 0x92, on endpoint id 1 cluster 0x0003: message send failure

I tried moving the bulb closer to the ZHA antenna, but that didn’t solve my problem. Any help would be appreciated!


I tried to add it several times now. What happens every time is this:

  • pairing is succesful
  • device shows up, entity with the right controls is created
  • bulb doesn’t respond to commands
  • after a while, the device becomes “unavailable” in HA. (Probably due to not responding to commands?)

I’ve attached my home-assistant.log, filtered on the occurence of the devices network ID (0x18f2). Perhaps someone can understand what’s going on here.

Well, I was going to attach that log file, but apparently, I’m only allowed to attach image files. And it is too large to paste.


Hi, I am not sure if I am able to help. Anyway, I am also thinking about buying these bulbs. If you can save the logfile enywhere on the internet, I’m curious and will try to interpret it somehow. I belive that some sort of ZHA quirks might help…

I have this bulb too. It does react to my commands (brightness and color temperature). But I cannot control the color. Can you?

In my case, the bulb doesn’t react at all. However, my Zigbee stick is a very old one, I suspect that it’s a compatibility issue because of that. I’m planning to replace it with a newer stick. Hope that will solve my problems.

I have upgraded to a new Zigbee cooridnator stick (The Sonoff Zigbee 3.0 + stick), and now the bulb works like a charm. Conclusion: the bulb wasn’t the problem, the coordinator was.

So I just stumbled over this issue as well. I got 10 Tradfri Bulbs connected to my HA ZHA and 3 are not responding to anything. Those three are “TRADFRIbulbT120E27WSopal470lm” bulbs - the ones that look like giant TicTac (TRÅDFRI LED-Leuchtmittel E27 470 lm, smart kabellos dimmbar/Weißspektrum röhrenförmig - IKEA Deutschland)

All others work fine. I use a relatively old dresden electronics RaspBee. The bulb and gateway worked fine together with my old hombridge installation. So I’m sceptical, that it is a hardware issue.

I don’t know about the RaspBee, but in my case installing a new Zigbee gateway solved the issue.

I can totally recommend the The Sonoff Zigbee 3.0 + stick. Works very well.

Its a bit late, but maybe someone is still having the problem (I was until today).
I bought two Tradfri Led 1055lm Ikea bulbs. I have a Conbee 2 as my cordinator connected to HA via ZHA.
I was able to “pair” the bulbs to ZHA by turning them on and off 6 times and then looking for devices, but after a couple of seconds they became unresponsive to any command. I found out today that if right after the bulb was detected by ZHA and before it became unresponsive you cut the power to the bulb it is correctly paired.

Hope it helps someone, cheers.

I have >50 Trådfri bulbs, including the 1055lm ones, and they sometimes drop off the network after a few months, but I’ve never had issues pairing them to a Conbee 2 with either ZHA or deconz. For pairing with ZHA I always pick a device near them and choose the “add via this device” option. Maybe that would help.