Tradfri E1812 button only showing battery usage


I’m new with Home Assistant and just bought these buttons at Ikea (model tradfri E1812 in fact)

I have a conbee II zigbee dongle and I was able to pair my buttons to my environment, however, there is no useful entity except the battery level… do you have any tricks to fix that? A working template?

I found this:

And a recipe by using zigbee2mqtt:

But ideally I would stick with a native zigbee integration.

You use ZHA or zigbe2mqtt?

If you use ZHA, go to Developer Tools then Events under Listen to Events type zha_event and start listening. Now click a button on your remote and see if something pops up.

I am using ZHA.

Here is the event:

    "event_type": "zha_event",
    "data": {
        "device_ieee": "58:8e:81:ff:fe:3e:eb:64",
        "unique_id": "58:8e:81:ff:fe:3e:eb:64:1:0x0006",
        "device_id": "31ddb86ea169f066a01188c2eb3936fd",
        "endpoint_id": 1,
        "cluster_id": 6,
        "command": "on",
        "args": []
    "origin": "LOCAL",
    "time_fired": "2021-02-04T12:04:17.469698+00:00",
    "context": {
        "id": "5315e08e5e1ea1e0448b09a6ebe469b0",
        "parent_id": null,
        "user_id": null

okay, there you have it. You can now use this to trigger any automation you want.

1 Like


Thank you for guiding me, I appreciate! I’m so happy Home Assistant so far and this community is just one of the reason why I like it so much.

I was a little confused with how to manage that, I was trying to develop a new event type…

Here is my automation!

alias: 'CUISINE: Bouton café'
description: ''
  - platform: event
    event_type: zha_event
      device_ieee: '58:8e:81:ff:fe:3e:eb:64'
      unique_id: '58:8e:81:ff:fe:3e:eb:64:1:0x0006'
      device_id: 31ddb86ea169f066a01188c2eb3936fd
      endpoint_id: 1
      cluster_id: 6
      command: 'on'
      args: []
condition: []
  - scene: scene.fermer_le_cafe
mode: single

Now you confuse me xD. you say that is your automation, but that is the event. You have to use the event as a trigger within an automation. Is that clear or not?

1 Like

Oh boy you’re right. It’s a bad copy-paste and I did not validated before posting my comment… I updated my original post!!

And BTW it’s working perfectly. So far it’s not fancy but tonight I will implement a toggle between 2 scenes attached to this button.

Okay, that looks good. If you want, you can get rid of some redundancy here, but that is not needed.

      device_id: 31ddb86ea169f066a01188c2eb3936fd
      command: 'on'

should be all the event_data you need.

1 Like

Thanks again for the useful comments!

I’ve just bought an Ikea Tradfri E1812 button and I’m having difficulties pairing it with my Conbee II stick.
The thing is I cannot even have the back lights flash red :man_shrugging:

I followed those instructions :
I tried clicking 4 times the tiny reset button on the back and also tried pressing it for 10 seconds.
Actually I was able to have the lights flash red only once after pressing for 10 seconds.
Which did not allow the Conbee stick to pair anyway…

Either I’m missing something in the pairing process or the button is very picky.
So I’m curious to know if anyone else was able to pair that E1812 to Conbee at all before I waste too much time on it, thanks for your advice ! :crossed_fingers:

Replying to myself.
I was able to pair the button eventually but it’s really a hit or miss :confused:
I changed the battery with another one I knew had juice but I’m not sure that’s the reason it worked…
Oh well, I’m good to go now.

Will continue my questions on that thread.

1 Like

In my case, battery level is reported as 0% (whereas the button works just fine)

What zigbee integration are you using? I do have a conbee stick as well, but I am using the ZHA integration.

Maybe that’s the difference.

It’s working now, must have been a slight delay.
Using Deconz / Conbee II stick

1 Like