Tradfri still not working - any ideas on status/priority

I am really missing my tradfri integrations, and are still having this error (below) do any of you know if this will has a dependency that is not worked on anymore, or is it just incompatible with my setup?

Log Details (ERROR)
Tue May 28 2019 20:49:44 GMT+0200 (Central European Summer Time)
Error handling request
Traceback (most recent call last):
  File "/srv/homeassistant/lib/python3.6/site-packages/aiohttp/", line 418, in start
    resp = await task
  File "/srv/homeassistant/lib/python3.6/site-packages/aiohttp/", line 458, in _handle
    resp = await handler(request)
  File "/srv/homeassistant/lib/python3.6/site-packages/aiohttp/", line 119, in impl
    return await handler(request)
  File "/srv/homeassistant/lib/python3.6/site-packages/homeassistant/components/http/", line 33, in real_ip_middleware
    return await handler(request)
  File "/srv/homeassistant/lib/python3.6/site-packages/homeassistant/components/http/", line 68, in ban_middleware
    return await handler(request)
  File "/srv/homeassistant/lib/python3.6/site-packages/homeassistant/components/http/", line 216, in auth_middleware
    return await handler(request)
  File "/srv/homeassistant/lib/python3.6/site-packages/homeassistant/components/http/", line 115, in handle
    result = await result
  File "/srv/homeassistant/lib/python3.6/site-packages/homeassistant/components/config/", line 154, in post
    return await super().post(request, flow_id)
  File "/srv/homeassistant/lib/python3.6/site-packages/homeassistant/components/http/", line 46, in wrapper
    result = await method(view, request, *args, **kwargs)
  File "/srv/homeassistant/lib/python3.6/site-packages/homeassistant/helpers/", line 86, in post
    result = await self._flow_mgr.async_configure(flow_id, data)
  File "/srv/homeassistant/lib/python3.6/site-packages/homeassistant/", line 80, in async_configure
    flow, step_id, user_input)
  File "/srv/homeassistant/lib/python3.6/site-packages/homeassistant/", line 98, in _async_handle_step
    result = await getattr(flow, method)(user_input)  # type: Dict
  File "/srv/homeassistant/lib/python3.6/site-packages/homeassistant/components/tradfri/", line 51, in async_step_auth
  File "/srv/homeassistant/lib/python3.6/site-packages/homeassistant/components/tradfri/", line 150, in authenticate
    key = await api_factory.generate_psk(security_code)
  File "/srv/homeassistant/lib/python3.6/site-packages/pytradfri/api/", line 195, in generate_psk
    self._psk = await self.request(command)
  File "/srv/homeassistant/lib/python3.6/site-packages/pytradfri/api/", line 155, in request
    result = await self._execute(api_commands)
  File "/srv/homeassistant/lib/python3.6/site-packages/pytradfri/api/", line 146, in _execute
    _, res = await self._get_response(msg)
  File "/srv/homeassistant/lib/python3.6/site-packages/pytradfri/api/", line 95, in _get_response
    r = await pr.response
  File "/srv/homeassistant/lib/python3.6/site-packages/aiocoap/", line 718, in _run_outer
    await cls._run(app_request, response, weak_observation, protocol, log)
  File "/srv/homeassistant/lib/python3.6/site-packages/aiocoap/", line 743, in _run
    await protocol.find_remote_and_interface(app_request)
  File "/srv/homeassistant/lib/python3.6/site-packages/aiocoap/", line 293, in find_remote_and_interface
    if await ri.fill_or_recognize_remote(message):
  File "/srv/homeassistant/lib/python3.6/site-packages/aiocoap/", line 179, in fill_or_recognize_remote
    return await self.token_interface.fill_or_recognize_remote(message)
  File "/srv/homeassistant/lib/python3.6/site-packages/aiocoap/", line 327, in fill_or_recognize_remote
    remote = await self.message_interface.determine_remote(message)
  File "/srv/homeassistant/lib/python3.6/site-packages/aiocoap/transports/", line 328, in determine_remote
    dtlsparams = self.ctx.client_credentials.credentials_from_request(request)
  File "/srv/homeassistant/lib/python3.6/site-packages/aiocoap/", line 285, in credentials_from_request
    raise CredentialsMissingError("No suitable credentials for %s" % uri)
aiocoap.credentials.CredentialsMissingError: No suitable credentials for coaps://

It should work fine and no breaking stuff that I know of. Did it work before? And if so do you happen to have a new setup you are trying this on? The Tradfri hub requires a dependency to work:

$ sudo apt-get install autoconf

Without this it won’t work. If you do have this dependency, try to remove it completely and repair it again. Alternatively you could use the homekit controller to connect your Tradfri bulbs. You will however need to remove Tradfri from the exceptions list in the Homekit Controller component (you will need to find the .py file in the components directory, usually /site-packages/homeassistant/~) will try to find the exact location if I have access to a computer. What this would do is not use the integration from HA, but the Homekit integration (like it would on Apple devices). It would probably work exactly the same as the HA integration with the exception of needing the security key (you will only need homekit code for this). If I am correct you will only have to edit the file once, as it only needs to be paired, because updating HA would reset that file. You would however need to do the same steps when adding new devices (which is not necessary when using the HA integration).

Apart from the pairing process (and maybe entity names) operation would be exactly the same as using the integration. Just make sure the hub isn’t connected to homekit already, if so you will need to remove it from your apple devices and pair it with HA instead (you can then pass it back to ios with the Homekit Component).

Note: The Homekit Controller has NOTHING to do with the Homekit Component. The Homekit controller is meant to connect devices through the Homekit protocol with your Home Assistant instance whilst the Homekit Component is meant to make incompatible entities compatible with Homekit. You do NOT need Apple devices to pair this with HA, and you do not need iphones etc to operate this.

To enable the homekit component in your setup add the following to your configuration.yaml

    - homekit

Thanks for that, I have tried removing autoconf and installing again. Not sure what you mean by repairing? But nothing changed. And yes, it has worked for a short while not sure in what version of HA it worked, and I have not changed my setup fundamentally since that. Now I am considering to re-install my virtual environment, to see if that might change things…

You could also setup a second virtual environment just to test it (that way you don’t have to shut down your current setup).

Oops auto correct on the repair, I meant remove the tradfri config. You can do this from the UI (settings>integrations). And then try adding it again. Restart the HUB to be sure.