Tradfri Unavailable

Hi All,

For testing purpose i purchased a Ikea Tradfri Motion Sensor.
I looks to be working fine but after a long idle time it goes to “Unavailable”

When moving in front of it it reacts so thats not the problem. Is this normal behaviour?.
I’m using ZHA integration with a Sonoff Zigbee Bridge (Tasmota firmware)

You’re not alone :

1 Like

After reading that i sounds like the motion sensor is the problem.
I also use motion sensors from Xiaomi and Philips Hue that are reporting “No Motion” like they should.

I’m playing with one of these IKEA Tradfri motion sensors too as they are the easiest one to buy here for a fair price. I assume it’s because the device does not report often enough, saving battery life.

I also see ‘unavailable’ as the state most of the time. Is there a parameter in HA that can make it ignore the sensor sleeping for longer ?

Anyone got this issue tackeled? Just bought a sensor to try and I experience the same issues…

Same here. Was working fine for quite a year without this behavior.

Since a few weeks, in the night all my 3 tradfri motion become unavailable until triggered by motion again in the morning.

Wierd thing is, another Tradfri Motion Sensor, in another room does not become unavailable.

It’s really not usable like this, I installed it in a secondary toilet, which is not used a lot (exactly for that reason it needed to be automated light)

I am currently experiencing the same issue with 1 out 6 similar IKEA motion sensors (704.299.13). All others work fine ever since.

Not sure why. It can’t be reception. I reconfigured it in ZHA, maybe that helps - even though it said that it failed to do so.

I have this same issue and last night completely by accident I ran into a setting that may be the cause of this. Under the ZHA dashboard ( http://homeassistant.local:8123/config/zha/dashboard ) there are two settings called “Consider [battery|mains] powered devices unavailable after (seconds).” It defaults to 6 hours for battery which makes sense why my motion sensor would go unavailable over night. After setting it to 86400 (24h), the motion sensor works as I expect.

The downside is that if you have a sensor that is not trigger in a 24 hour period it will still go unavailable. I haven’t tried to test for the value’s upper limit. I tested it with a zero value and that doesn’t disable the setting. I’d really rather disable this setting.

Since I am new to HA and ZHA I am not certain how to file a bug report.


That helped a lot! At least now they stay “clear” if activated every 24h!