Tried all GPIO pins, none will trigger relay/led/etc

Hi all, I bought a few milfra mfa05 light switch last week, however they are new versions with CBU board instead of esp8266 in this post. I successfully flashed it with tuya-cloudcutter, but I couldn’t find any GPIO pin out. I’ve tried gpio scan from esphome-kickstart, as well as mark all gpio pins as relay, but none of them will trigger the relay in the switch. In the meantime, the physical button still works, and can trigger the relay. I even tried openBK, same result, none of the GPIO will do anything.
Any ideas what’s going on here? Everything looks good on esphome ad openbk, I
just can’t get the gpio to work…

Comparing which pins are soldered to this: CBU Module Datasheet-Tuya Developer Platform-Tuya Developer

You have:

Pin1 : GPIO14
Pin7: TX2
Pin8: GPIO8
Pin13: GND
Pin14: 3V3
Pin15: TX1
Pin16: RX1
Pin21: GPIO15

I don’t actually see a relay or anywhere the mains power connects. Is there a second PCB?

Could it be using tuya mcu now?
Have you tried getting dpid if any?

Yes, these is another PCB, connect to this one via the plug, I will post a photo of it later today.

Ah, this could be the reason, I will look into it this afternoon, futunately I still have a few units with stock firmware, hope it will make the process easier.

update, confirmed its a tuya mcu device, I haev successfully extracted the dpids from tuya website. Most of the DPid works flawlessly, however I can’t make DPid 15, which is the status LED to work.
update: fixed

The other side of the pcb, with the male connector