Trigger zwave_js_value_notifcation not working anymore

Up until a few weeks ago I had the following trigger running:

- alias: livingroom_tv_scene_activation_triple_click
  - platform: event
    event_type: zwave_js_value_notification
      node_id: 2
      property_name: sceneId
      value: 25

When I tripple clicked a button on my Fibaro wall switch I could activate something, a scene, garden lights, anything basically.
It worked fine, I had to change somethings in April because of the change in zwave_js but it worked.

At the moment I cannot find anything on why it is not working anymore and was wondering if anyone could give me some pointers.

When I listen to zwave_js_value_notification I get:

    "event_type": "zwave_js_value_notification",
    "data": {
        "domain": "zwave_js",
        "node_id": 2,
        "home_id": 4181654489,
        "endpoint": 0,
        "device_id": "899085d8d14b8204e204ce758b96b3cd",
        "command_class": 43,
        "command_class_name": "Scene Activation",
        "label": "Scene ID",
        "property": "sceneId",
        "property_name": "sceneId",
        "property_key": null,
        "property_key_name": null,
        "value": 25,
        "value_raw": 25
    "origin": "LOCAL",
    "time_fired": "2021-10-25T07:46:11.651950+00:00",
    "context": {
        "id": "272455423001df5476e748f2bc0cb2c8",
        "parent_id": null,
        "user_id": null

I have similar triggers for Fibaro devices but I don’t include the “property_name” item. I’d suggest trying two things: remove the whole “property_name” line and/or put “sceneId” in quotes.

1 Like

Thank you!

Removing the “property_name” line solved it.