Trouble adding Blueiris Camera in Home Assistant

I have HASS running in Docker and cannot get any camera from Blueiris to show up in HASS.

Spent last couple days reading many threads on this topic and tried to add BI camera in HASS. None of them worked for me.

Picture entity shows a broken svg in a grey frame (no actual image or video) and “Idle”.

URL for the stream and still image works fine in FireFox and VLC as well as in a iFrame within HASS but NOT in camera.

Unchecked “use secure…” option, tested with “non-lan only”, and “no connections”.
Also tested with and without credentials in config.yaml, set “verify_ssl: false”, removed it, tried still_image_url, and various combinations of the above as well as turning off firewall(s).

Both are on same LAN segment/subnet. Didn’t find any errors in logs. I ran out of ideas. Any help is appreciated!

Home Assistant : 0.90.1 (docker / on Linux)
BlueIris : x64

Can you show us the yaml that you are using?

Thanks for replying! I posted in other forums and even on a same-topic thread and haven’t heard a thing.

Anyway, here it is:


  - platform: mjpeg
    name: Porch
    username: <username>
    password: <password>
    authentication: basic   
    verify_ssl: false


  - title: TEST_TAB
    badges: []
      - type: picture-entity
        title: CAM1
        entity: camera.porch
        camera_image: camera.porch

instead of adding authentication in teh configuration try leaving it directly in the URL like http://user:pass@ip:port/mjpg/<camera shortname>

Tried formatting my URL as you suggested and nothing again.
Here is what I tried:

BI - [no connections] and [✓] OR [_] Use secure session keys and login page.
HASS: NO camera.
VLC: Opens stream without any issue.
Browser: Got a warning prompt and click “Yes” opens the stream in FireFox.

BI - [non-LAN only] and [✓] OR [_] Use secure session keys and login page.
Exactly same results as Test1.

BI - [All Connections] and [_] Use secure session keys and login page.
Exactly same result as Test1 except:
FireFox Prompts stating "You are about to log into <site…> with " OK / CANCEL and clicking OK opens the stream.

with [✓] Use secure session keys and login page.
HASS: still NO camera.
FireFox: Displays the screenshot Warning prompt twice and after YES for both, BI login page comes up. If I put username & password there, then stream opens.
VLC: Does not open the stream.

Just to make sure, I cleared “Everything” (incl. autofills etc.) from Firefox and closed it before each iteration / test.
Likewise, BI was restarted (running as service) after each individual change (just wanted to make sure web server is reloaded with new settings… probably unnecessary but whatever).

When you run Test2 (authentication for non-LAN only) try to whitelist the IP for HA in the text box like ^ for example, keep the ^ in front

When you do this you should not need the username/password in the URL

1 Like

Wouldn’t that be the same thing as selecting “No Connections” and unchecking “use secure…”. Essentially, (from what I can understand) all authentication should be disabled…

I have done this (whitelist IPs) in BI before when testing this issue. Nevertheless, I will try it again as it is possible I missed a step.


Your help and my persistence paid off! I was about to give up thinking it might be a codec issue and now, for the first time, I was able to see HASS camera show BI camera output. Right now, it is just still image updating every 10 seconds. Now that I know that it CAN, I’ll tweak and get the rest going. Unbelievable!

The funny part is that I have done this (whitelist I mean) step before. Apparently, either I didn’t reboot HASS or BI at that time.

Whatever it is, Thank you dshokouhi!

For future viewer(s), here is what worked for me:
For testing purposes at least, move both HASS and BI on the same subnet.
And, here is the screenshot of BI > Settings > Web Server > Advanced:

Restart BI & Reboot HASS and in that order. This step may not be required for you but, for my setup, it proved to be the one thing I missed all along.
And, of course check and make sure your config and entity yaml is correct.

I will edit this post with final working config (right now its a lot of comments etc., and I am still experimenting).

1 Like