Trouble adding Schlage Connect Be469 to ZWave JS

Hello, I’m completely new to Home Assistant, but I purchased a Zooz 700 series stick and installed HASS on a virtualbox on my old mac mini, currently 2022.11.5. I have a couple of Zooz light switches installed fine but am having difficulty with the Schlage Connect BE469 lock.

I was successful a month ago adding it to my ZWave network but it started to fail out and lose connection periodically so I removed it from ZWave JS (rookie mistake as I’ve read). I’ve read multiple forum entries and tried everything to re-add back to ZWave JS. I’ve gone through 4 sets of new batteries, I have my Zooz stick on a USB extender stuck directly to the deadbolt, factory reset it about 40 times (followed the instruction manual), tried to exclude (at factory reset the Schlage light on the inside does not light up) and cannot get past the touchpad’s red x indicating no enrollment. When I have the log running on a separate computer, there is no activity as I’m trying to enroll the lock.

I’ve read I need to update my Zooz stick firmware so will try that tomorrow after getting the registration link from the company.

Are there any steps I’m missing? I’ve excluded all the light switches except one, so there are only two zwave devices showing up at the moment (controller and one light switch).

Appreciate any help!

First - is this the BE469 Pre ZWave Plus lock or is it the 469 Zwave Plus? (The plus has an include / exclude button on the inside of the housing whereas the older one only uses programming codes.)

If it’s the older one you MUST pair it within 6 inches of the lock. (It uses S0 Whisper mode pairing and it’s honestly the worst thing about the lock - I have to put my ZStick literally on top of the lock to get it to re-pair - I own a 25’ cat 5 patch cable SPECIFICALLY for this.) Manually factory reset the lock and restart your Zstick before you start pairing.

Also the 469 isn’t ENTIRELY standards compliant when it’s being interviewed and more than half the time it will fail to interview properly. Ping, Repair, Re interview until it comes in. (Keymaster should work even if it doesnt re-interview properly IF your lock is reporting the usercodes properly)

Finally these things need a beaming repeater to store and forward messages - I always install a beaming capable smart switch in close proximity to any door with a Schlage or Yale Zwave lock. It will help it keep from ‘falling off.’

1 Like

I have the pre-Zwave plus (no orange button on the board). I have my zooz stick literally taped to the deadbolt, I’m talking millimeter away. I’m moved the entire rig next to my front door to test. I’ve updated the stick to the new firmware will test later tonight.

When you say restart the zstick, do you mean restart zwave JS? Or is there another procedure?

I’ll look at installing a zwave switch to my front door light that is beaing capable, will get on that right away.

I’m still getting red x’s and no pairing. I’m concerned nothing is showing up on the logs when I try to pair. However, I’m not exactly sure I’m looking at the right place.

1 Like

Did you factory reset AND exclude (yes both) before attempting to include? (factory reset does not automatically exclude the ZWave chip pre-Zwave plus. That was added to the spec for plus.)

Here is my exact procedure:

  • Shut down HA and carry the rig to my lock. (this also handles shut down of the stick and reset of ZWaveJS UI)
  • Tape z stick to lock (or get wife to hold it - she wasn’t thrilled with the idea though)
  • Startup HA, wait for HA/ZWaveJS/JsUI
  • Open ZWave include/exclude, start exclusion and run the lock’s exclusion procedure.
  • Factory reset the lock
  • Now try to include. (it should go at this point)
  • Wait for silliness in progress (interviews etc)
  • Tear down the HA rig, return it to normal location
  • ZWave repair the lock. (it still thinks it should be routing directly to the z stick)
1 Like

Thanks for the instructions. I’ve done exactly as you said (minus the wife) up to factory reset. When through the exclusion steps but cannot get the lock to play ball. According to the Schlage instructions, the include/exclude steps are the same. Here is where I get stuck. Following the steps, I never get a green check box.

It always turns to the red “X.” The logs also don’t show anything.

Blockquote2022-12-03T01:17:54.378Z CNTRLR starting exclusion process…
2022-12-03T01:17:54.425Z CNTRLR The controller is now ready to remove nodes
2022-12-03T01:18:46.591Z CNTRLR stopping exclusion process…
2022-12-03T01:18:46.640Z CNTRLR the exclusion process was stopped
2022-12-03T01:18:58.855Z CNTRLR starting exclusion process…
2022-12-03T01:18:58.890Z CNTRLR The controller is now ready to remove nodes
2022-12-03T01:20:07.591Z CNTRLR stopping exclusion process…
2022-12-03T01:20:07.643Z CNTRLR the exclusion process was stopped
2022-12-03T01:20:49.943Z CNTRLR starting exclusion process…
2022-12-03T01:20:50.007Z CNTRLR The controller is now ready to remove nodes
2022-12-03T01:21:21.450Z CNTRLR stopping exclusion process…
2022-12-03T01:21:21.509Z CNTRLR the exclusion process was stopped
2022-12-03T01:22:36.595Z CNTRLR starting exclusion process…
2022-12-03T01:22:36.628Z CNTRLR The controller is now ready to remove nodes

Funny enough when I factory reset the lock, the inside Schalge button does “blink” indicating that it is still enrolled. I stumbled across this forum thread, and have looked at the stick, but it only shows two nodes at the moment. The stick and my one light switch still connected to the system.

I guess my problem is being able to exclude the lock.

Don’t try and pair the lock in HA or ZWAVEJS, you can do everything directly from the stick with the software on the computer. That’s my recommendation, see if you can get it to pair at all without adding in the extra variables.

What do you mean? The controller (stick) can’t be used without HA (add-on)/Z-Wave JS or some other host software.

1 Like

I tried using the pc zwave controller a handful of times directly. Still could not get the lock to exclude. I’m hitting the “remove” option in the software and it just times out, never getting a confirmation it’s worked. I’ll try several more times after using the default code to start up its cycle right after factory reset before trying to exclude. Cannot for the life of me get a green check mark for either exclude or enroll on the lock after going through all the steps.

Tempted just to go get another lock. Sigh….

Agreed, he referenced my post & my recommendation was to use the software to directly interface with the controller just to remove the other potential pain points.

It’s all theoretically the same anyways.

Have you tried to factory reset the stick itself? I see you only have a couple devices, it’s worth a shot.

Factory reset the stick too. Confirmed it’s working fine after adding one light switch more than 20 feet away.

I’ve followed @NathanCu steps. Factory reset the stick and lock. Confirmed the zwave stick firmware is updated and working (enrolled light switches fine). Stick is still taped to the lock and the whole process done using both the PC controller software and through home assistant zwave JS. After factory resetting the stick, factory reset the lock, enter default user code to have the lock go through initial setup, enter “remove device” in home assistant, enter programming key and hit zero to start enroll/exclude mode. Still getting no response from keypad and nothing showing up in logs. I’ve tried again with fresh batteries and move the stick both stuck on the back and front of the keypad.

Starting to think something’s wrong is the circuit board on the lock now. I emailed Schlage to see if I can get a response.

1 Like

Do you have the network keys set?

You need to navigate to the zwavejs2mqtt control panel at yourIPaddress:8091

Click the gear on the left, then scroll to “zwave” (under general).

Make sure all 4 keys are defined. If there are any blank, you can click the picture of the two arrows to generate a random key. Be sure to scroll down and hit save when you are done.

I am haivng the exact same issue with the a similar install Zooz/NUC HA/old Schalge deadbolt. Also see nothing in logs. Tried add device a thousand times. Inches apart. This lock worked fine with my old Vera. So it was paired with the Vera until today. I would unpair it, but the vera is toast (that’s why I went HA). I tried factory reset of the lock, and all the steps here including updating to latest zooz 7.18 from today. I did not install zwavejs2mqtt, I installed z-wave js. It self-gen’d keys, the config looks complete. Did anyone figure this out??

I got my lock to add to the stick by plugging it into my laptop and using the silabs software. The same software zooz had me install to update firmware. Use the network tool to exclude, then add it back, then plug the stick back into HA. Moving on to configure the old lock in HA. The default config is disappointing and does nothing. Going to search for a fix for that now.

The only thing I would mention as well is when I got these instructions to work I tried S2 Security with Force Security checked and S0 Security (with Force Security checked) and it worked. Not sure which one actually made it work.

Thank you very much for the instructions and the details on S0 whisper.

1 Like

Could you elaborate a bit on the beaming?
I have a Zooz zen27 which is supposed to support beaming Installed immediately next to my Schlage be469zp.
How do I know the beaming is actually working for the lock?
Haven’t all sorts of issues with lock going unresponsive to commands and batteries dying quickly at times also.

Sorry to revive this post…

I’m moving my Schlage BE469 lock from SmartThings to ZWave-JS. Following the advice in this thread everything seems to be pairing fine, the interview completes, it connects with S0_legacy status and I can see lock status entries I expect. What I can’t seem to do is update the those lock status entries.

If I manually operate the lock I see this error message:

2023-10-04T18:07:00.365Z CNTRLR [Node 028] command was received at a lower security level than expected - discarding it...
2023-10-04T18:07:00.366Z DRIVER « [Node 028] [REQ] [ApplicationCommand] [discarded]
notification type: Access Control
notification status: 255
notification event: Manual unlock operation

If I send a command from Home Assistant I see a timeout:

2023-10-04 14:25:57.110 DEBUG MQTT: Publishing to zwave/Entrance/Front_Door_Lock/lastActive: { time: 1696443957109, value: 1696443948551 } with options { qos: 1, retain: true }
2023-10-04 14:25:57.359 DEBUG MQTT: Publishing to zwave/Entrance/Front_Door_Lock/lastActive: { time: 1696443957359, value: 1696443957110 } with options { qos: 1, retain: true }
2023-10-04 14:25:59.421 DEBUG MQTT: Publishing to zwave/Entrance/Front_Door_Lock/lastActive: { time: 1696443959421, value: 1696443957110 } with options { qos: 1, retain: true }
2023-10-04T18:25:59.423Z CNTRLR [Node 028] Timed out while waiting for a response from the node (ZW0201)

I suspect an encryption issue which I think is caused by my controller. Can ask if people can lock and unlock from Home Assistant? And if you can, which ZWave dongle are you using.


Aeotec 5+

That looks like a broken include. The controller isn’t getting encrypted traffic therefore discarding it.

I assume as S0 your lock is the 469 standard - not the ZP (Zw plus version). Each will have its own set of issues. The biggest one with the non plus version is if you don’t include it literally right next to the controller it won’t join correctly. (S0 whisper mode)

You’re probably going to have to exclude / include again. But it could just be a comms issue. Have you tried a heal on that node yet?

Thanks for the quick reply.

I think you’re right, it’s the old version of the lock, I’ve had this thing 10+ years now.

I ran an extension when I included it and the stick was resting on the door lock. And I excluded and included it 5 or 6 times with the same issue. I ran out of patience today but I’ll try it again tomorrow.

By “heal” do you mean “rebuild route” from the advanced options on ZWave JS?

Yes. This terminology was changed within the last week’s releases. Any past references to “heal” are now “rebuild route” in the Z-Wave JS world.

1 Like