Trouble Connecting ESP32-WROOM-32

I have HA running in a VM via ESXI. I finally got to the point where i can upload to the board via “Plug into this computer”.

As far as network goes, im running a Dream Machine Pro and am using a dedicated 2.4 SSID. After i upload it stays offline. I tried assigning it a manual ip address and no luck.

Log with manual ip set

INFO Reading configuration /config/esphome/d132.yaml…
INFO Starting log output from using esphome API
WARNING Can’t connect to ESPHome API for Error connecting to (‘’, 6053): [Errno 113] Connect call failed (‘’, 6053)
INFO Trying to reconnect to in the background

Log with just the ssid and password set

INFO Reading configuration /config/esphome/d132.yaml…
INFO Starting log output from d132.local using esphome API
WARNING Can’t connect to ESPHome API for d132.local: Error resolving IP address: [Errno -2] Name or service not known
INFO Trying to reconnect to d132.local in the background

what am i missing? Thank you!

First thing first, is the ESP actually connected to the wifi? You should be able to see this from the controller.
And did you try pinging the device.

Always start at the basics when troubleshooting this kinda things. Without the ESP being connected to the Wifi anything else is going to be moot anyway.

yeah im not seeing it connected. What am i doing wrong?

Since it wont connect you did not enter the SSID and/or password correctly.
Can you past your config here? (without the actual password ofcourse)
And when u paste it here use the triple ``` How to help us help you - or How to ask a good question
So its readable on the forum.

ok lets see if this is better

  name: esp2
  platform: ESP32
  board: esp-wrover-kit

# Enable logging

# Enable Home Assistant API

  password: "c5f1840c588f1d920d985cb17d8ed378"

  ssid: "SSID"
  password: "PASSWORD"

  # Enable fallback hotspot (captive portal) in case wifi connection fails
    ssid: "Esp2 Fallback Hotspot"
    password: "DULUld0z6GVZ"


here is a pic of the esp32. i read on another thread that for the WROOM they just chose the generic option when selecting the board.

The config looks okay. You can try to add fast_connect: true so it wont scan and if for some reason the SSID is hidden its the only way it will connect.

  ssid: "SSID"
  password: "PASSWORD"
  fast_connect: true

Also, after you do this: Get our your phone and do a wifi network scan, if you see the Esp2 Fallback Hotspot
You will know for sure it failed to connect to your Wifi

its not showing up :frowning:
i connected to the same ssid as i put for the esp32
i used ubiquiti wifi man app on my phone to do a network scan
and nothing popped up resembling esp32 or esp fallback etc

i also have google wifi set up, i could try connecting to those. but not sure if the auto switching will mess it up. all my other iot devices dont like it.

You should just be able to look in your regular wifi phone settings and see the hotspot. It might be worth it to double check your settings for the ap and wifi network. Password type psk2 and the 2.4 g radio is active. Managment frames off.

You could also flash tasmota to check if the esp is indeed working correctly.

Ohhhhh im so sorry i thought by network scan, he meant scan all connected devices. Yes i do see the Esp2 Fallback Hotspot.

So the SSID is WPA-2 and the management frames are off.
2.4 g radio is active.

Should i try tasmota next?

ok then
if you can see Esp2 Fallback Hotspot.that means it it can’t connect to your network its thinking password could be wrong or ssid could be wrong or the DHCP in router is not handing out IP address

log still says

INFO Reading configuration /config/esphome/esp2.yaml...
INFO Starting log output from esp2.local using esphome API
WARNING Can't connect to ESPHome API for esp2.local: Error resolving IP address: [Errno -2] Name or service not known
INFO Trying to reconnect to esp2.local in the background

should i try creating another 2.4g ssid and see if that works? Otherwise how do i figure out if the DHCP is the problem?

no what the route you are using

That error just means ESP is not finding the module on the network.
Is your phone connected to that network? if not, try to connect your phone to it. (the 2.4Ghz one)

Unifi Dream Machine Pro

1 Like

i am connected to it. you mean the 2.4 ssid right? not the fall back hotspot.

---------- i just got a message saying i cant reply anymore because im a new user :frowning: --------

Can any mods remove that from my account? I was really enjoying this :slight_smile: @Dujith @myle

if it a router form you internet provider they are check and been setup on only let a small number of thing connect to it

ok Unifi Dream Machine Pro that not the problem then

Yes, the 2.4 SSID you made for the ESP