Trouble getting HADashboard Up and Running

As the title suggests, I’m trying to get HADashboard up and running but seem to be hitting hurdles at step one!

Following the instructions at I can’t even get the test dashboard happening.

Docker pulls the latest image fine, it starts fine, connects to Home Assistant fine, and appears to run the Hello World app fine. The next thing that the instructions state is that it will start a test dashboard, which I should be able to browse to on port 5050. This bit doesn’t happen, not sure why, and if I can’t even get the test to work, I’m not prepared to even think about starting to tinker with my own dashboards.

My command:
Edit: Yes DASH_URL does have http:// at the start, but for some reason the forum rearranges the order of the hostname and port if I include it in the code. ¯_(ツ)_/¯

server@server-ubuntu:~$ sudo docker run --rm -it -p 5050:5050
-e HA_URL=“
-e HA_KEY=“##########”


2018-05-08 15:29:22.770638 INFO AppDaemon Version 3.0.1 starting
2018-05-08 15:29:22.770870 INFO Configuration read from: /conf/appdaemon.yaml
2018-05-08 15:29:22.773018 INFO AppDaemon: Starting Apps
2018-05-08 15:29:22.776731 INFO AppDaemon: Loading Plugin HASS using class HassPlugin from module hassplugin
2018-05-08 15:29:22.824026 INFO AppDaemon: HASS: HASS Plugin Initializing
2018-05-08 15:29:22.824431 INFO AppDaemon: HASS: HASS Plugin initialization complete
2018-05-08 15:29:22.824655 INFO Dashboards are disabled
2018-05-08 15:29:22.824759 INFO API is disabled
2018-05-08 15:29:22.832354 INFO AppDaemon: HASS: Connected to Home Assistant 0.68.0
2018-05-08 15:29:22.856070 INFO AppDaemon: Got initial state from namespace default
2018-05-08 15:29:24.921498 INFO AppDaemon: Reading config
2018-05-08 15:29:24.923593 INFO AppDaemon: /conf/apps/apps.yaml added or modified
2018-05-08 15:29:24.923762 INFO AppDaemon: /conf/apps/apps.yaml added or modified
2018-05-08 15:29:24.923869 INFO AppDaemon: App ‘hello_world’ added
2018-05-08 15:29:24.924036 INFO AppDaemon: Adding /conf/apps to module import path
2018-05-08 15:29:24.924395 INFO AppDaemon: Loading App Module: /conf/apps/
2018-05-08 15:29:24.934991 INFO AppDaemon: Initializing app hello_world using class HelloWorld from module hello
2018-05-08 15:29:25.048843 INFO hello_world: Hello from AppDaemon
2018-05-08 15:29:25.050584 INFO hello_world: You are now ready to run Apps!
2018-05-08 15:29:25.051423 INFO AppDaemon: App initialization complete

please share your appdaemon.yaml, because i think you have an error in your configuration, causing that the dashboard is disabled.

I don’t appear to have an appdaemon.yaml.

Unlike the manual installation, there’s no suggestion of an appdaemon.yaml in the docker tutorial, and anyway it appears the container populates it itself on startup?

if you followed the docker instructions then you did set a configuration directory.
(this part from the installation: Docker tutorial — AppDaemon 4.4.2 documentation )
the docker then automaticly puts all needed files for configuration in that directory.

the last line from that part has a link:

At this point forward, you can edit configurations on your conf folder and Appdaemon will load them see the AppDaemon Installation page for full instrctions on AppDaemon configuration. Have fun!

the link points here Getting started — AppDaemon 4.4.2 documentation

and that tells you that you need to configure appdaemon in the appdaemon. yaml in the directory you have set.

without that you cant do anything.

You’re not far off but you need to rectify this message by editing your appdaemon.yaml file

Correct, if I followed that far, but I’m not at Persistent Configuration yet.

I’m here, at Testing Your System which is not functioning as described.

The instructions state that that after this…

2017-04-01 14:26:48.330084 INFO hello_world: Hello from AppDaemon
2017-04-01 14:26:48.333040 INFO hello_world: You are now ready to run Apps!

you will get this…

2017-04-01 14:26:48.348260 INFO HADashboard Started
2017-04-01 14:26:48.349135 INFO Listening on (‘’, 5050)

upon which you can browse to http://[myserverip]:5050 and see a test dashboard…

Now open up a web browser, and browse to http://:5050. You should see the “Welcome to HADashboard for Home Assistant” screen and see the Hello dashboard is available.

This is not happening.

No suggestion of YAML and no defining of a config directory at this stage, it appears to simply be a test container that theoretically should just work?

OK so I’ve semi solved this.

I skipped over the Testing part of the tutorial and jumped straight to the Persistant Config part. Following those instructions, then adding the DASH_URL to the created appdaemon.yaml works.

Seems there is a problem with the test container.

testing before configuring can be helpfull, but its always a troublesome part.
glad you figured it out, ill notify @aimc about the error.