Trouble getting Sony Bravia XBR55X850C Linked with Home Assistant

So I have tried many times to get my Sony Bravia XBR55X850C linked with Home Assistant and can’t seem to figure it out. What happens is I start Home Assistant on my server and nothing happens on the TV so then I go to Home Assistant and push the configure button under my TV. Nothing happens on the TV so I put in 0000 as my pin and press enter. This fails but now the tv brings ups a 4 digit pin code but I have no where to enter this in Home Assistant. I look at the bravia.conf file and it has saved the 0000 pin.

I have tried the method to set a pre shared key from the TV but that doesn’t seem to work either.

I also had some troubles connecting the my Sony Bravia with Home Assistant. I was able to enter a pin code in HASS but the TV didn’t accept the code.

I then deleted the iPhone I was using to enter the code in the TV settings at:
Settings → Network → Home Network Setup → Remote Device / Renderer → Registered Remote Devices

After that I was able to registere HASS. Maybe this can help you.

But since some days I don’t have connection with the TV anymore. I can still switch it on in HASS, but it’s not showing the information from the TV anymore (on, which channel etc.). When I look in the logs it seems this happens since I upgraded to 0.26 last Sunday.
Anyone else experiencing this as well since the upgrade?

Ok I cleared all devices out and still no luck. I have the same problem as before. The wierd thing is I can see the state of the device and the history of it so something must be connected

I had trouble to pair my tv to Homeassistant.
without bravia.conf Homeassistant ask me for a pin but the tv does not (even after the 0000 thing)
with a brafia.conf file the tv ask me to enter the pin in 60 seconds but Homeassistant does not have the configuration panel.

At the end i modified adding
“request_configuration(config, hass, add_devices_callback)”
(at line 136 after the add_devices_callback)

This way i was able to input the correct pin and pair the tv.
Then i restored otherwise you would see 2 different bravia in the web interface.

Hope it helps.

Where is the file located at. I can’t seem to find one?

you can find a file with:
sudo find / -name

the full path of the file on raspberry is

Ok I tried this and every time I put in the pin in home assistant the TV says registration canceled after I hit enter

Ok it is now connected however nothing seems to work as far as buttons to control the TV. I can see what I am currently watching and the status of the TV but can’t change anything. Thanks for getting me this far though

Glad to help.
You shold at least be able to power on the tv (its a simple wake on lan).
Have you tried power on/off?

Yes I tried the power on/off and it didn’t work. I was able to see which program I was watching so I know it is connected but no luck with power on/off. I am on version 0.26.2 if that matters

So I enabled discover in my configuration and it found the TV automatically and for this instance I Caan turn the TV on however nothing else works. And I kept the manual instance also but could not do any commands with it. On the discover instance the state would say off when tv was off and idle when it was on

Hi everyone…

Can’t add my XBR-55HX925 on HASS.

It is listed as Remote Control Supported on 2011 XBR-HX92 series

Same error many claimed above…

Nothing happen neither when try to configure nor creating the bravia.conf.

My is different from the listed above as well, can’t find where add those lines…

Is there another way?

my is blank