Trouble moving devonz with Conbee 2 on raspi 4 from SD to SSD

Hello everyone,

for reliability reasons I want to run my raspi 4 with an SSD instead of an SD card. I followed this tutorial and everything worked great except with my zigbee setup.

I did a full backup of my perfectly running system from the SD card, flashed HassOS on my new SSD which i connected via USB dongle to my raspi 4 and had it boot up. After booting I setup a random user and location and after that I restored my full backup via Supervisor. The raspi 4 still has the same IP-adress so that shouldn’t be the issue.

My conbee 2 seems not to be connected to my Zigbee devices anymore, even though it still lists them in the Phoscon frontend. Also when checking the gateway in phoscon under current version it said the gateway was not connected. I found this solution to the connection error (just connecting the conbee 2 via usb extension cable to one of the usb 2.0 ports) however it still didn’t solve the problem with my zigbee devices.

I even tried to reconnect one of my ikea lightbulbs to the gateway, but deconz can’t find the buld.

Has anybody had the same issues and was able to solve this?

I have (had) exactly the same problem.

I moved from a system booting on an SD card to a new system that boots from an SSD. For that matter I am using an Argon One M2. The SSD is connected to the lower USB3 port with the special plug provided.

After restoring my system, I plugged the ConBee II. It was recognized but communication with the ZigBee devices was not working anymore (even though all devices were still visible). I though it was a problem of backup so I decided to remove all the devices from the network and paired them again. Unfortunately, after testing several devices none were able to be paired.

I did some search on the net and apparently the ConBee plug does not like to be used on a RPi that boots on an SSD.

Then I found your message and I have looked at the video that you mentioned and applied the recommendation of using an USB extension cable and now it works!

In fact, I was already using an extension cable and the ConBee stick was at about 30-40 cm from the RPi and now it is at about one meter. I am skeptical about the need to have a “minimum distance” between the SDD and the stick? I would be surprised that an SDD produce enough “radiation” to prevents the ConBee to work.

Maybe (probably) what makes the difference is that at the same time I moved the ConBee from the second USB3 port to one of the free USB2 port.

I am using ZHA to drive the ConBee and I looked at the log file from HA core. I had the following messages repeating:

2021-12-10 17:23:42 ERROR (MainThread) [zigpy_deconz.uart] Lost serial connection: device reports readiness to read but returned no data (device disconnected or multiple access on port?)

2021-12-10 17:23:42 WARNING (MainThread) [zigpy_deconz.api] Serial '/dev/serial/by-id/usb-dresden_elektronik_ingenieurtechnik_GmbH_ConBee_II_DE2234672-if00' connection lost unexpectedly: device reports readiness to read but returned no data (device disconnected or multiple access on port?)

This clearly indicates that the device is seen but communication with it is not possible. Now the message is gone. I have already paired some router and end devices without problem.

This is a very strange problem but I would like to be sure what is causing it. So, I will probably make the following tests to be sure what is really causing the problem:

  • With the stick connected to the current USB2 port I will try to put it close to the SSD a see if continues to work

  • Try to connect the stick to the other USB3 port and place it far from the SSD

The bad news is that now I have to rebuild my network … But at least it works

As you already tried to move away the stick, try to put it on one of the USB2 port and let me know if it works

1 Like

Thanks for your reply. I will also have a look at switching to ZHA and trying to position my conbee 2 stick farther away from my pi. I already have my conbee connected via USB 2 but I’ll just try the other port as well.
If the distance is actually the problem here, this would be really weird. Though if it’s stupid and it works it’s not stupid as they say.

Will keep you updated and would appreciate it, if you update me once you are done troubleshooting.

Actually it’s not 100% true.
It’s not about Z2M, ConBee or rPi booting from SSD. The last is the closest reason but not exact.

It’s about interference with USB3 ports. It’s possible that the fenomenon doesn’t exist when nothing is connected to USB3 ports.
Depending on stick positioning against rpi, rpi casings etc the distance might vary. I had to use 2m USB extension cable to make it stable.

1 Like