Trouble porting platform to new format - HA just hangs :-(

HA Version : 0.93.2
Hey guys,

Im trying to port my wiser heating extension from the old “components” method to the new one… For some reason when I run HA , HA just doesnt start… No notable errors in the log files just doesnt start… If i remove the component reference in the configuration.yaml , it starts (sans the component)…

Im baffled… Any ideas??

the code is available at this branch in github

the config file would look like this

  password: xxxxxx
  scan_interval: 300
  boost_temp: 25
  boost_time: 30


im baffled…

I thought you need a manifest file too now.

Sorry yes you do. was an error in my .gitignore, it was ignoring manifest files…

note to self : dont reuse .gitignore files…

Pushed new version

thanks for looking BTW

Have you tried disabling all functionality in setup?

Robban, not sure what you mean… which setup? the one in the code?

Everything in def setup(hass, config):

i commented out everything in the setup(hass,config): method an its the same.
The only way HA starts is if it remove the reference to the platform from the config file…

Put the .py file in the root custom_components dir.


I figured out whats causing it… Its the new manifest.json file. If i take the file out then it works!

After a lot of checking/comparing with another manifest file which does work I sussed it

I was missing the “dependencies”: [], section. without this instead of giving an error HA Startup just hangs…

logging an issue

shame it wasted 2 evenings :frowning: