Trouble renewing Letsencrypt

Hello for the last year or so I have been renewing my cert. with this string

./certbot-auto renew --quiet --no-self-upgrade --preferred-challenges tls-sni-01

I got a email to renew so I tried updating and its not updating.
I have the ports forwarded (80 and 443) never had a problem before.
I am running HA 0.49.1 because all my IOS devices are on IOS 9
I read something about the challenges tls-sni-01 was disabled, but can still be renewed

Maybe I have been updating wrong. hope some one can help Thanks

Try removing --quiet and see what messages you get.

Since it’s a problem with renewing, you may want to ask for help on the Let’s Encrypt forums.

@Tinkerer well its weird I removed the --quiet watched it and it said succeeded, I thought it worked. checked HA it didnt update so I tried again and got a error

Attempting to renew cert from /etc/letsencrypt/renewal/ produced an unexpected error: urn:acme:error:rateLimited :: There were too many requests of a given type :: Error creating new cert :: too many certificates already issued for exact set of domains: see Skipping.

I guess I’ll check Let’s Encrypt forums Thanks