Trouble setting up development environment

I been trying to setup the development environment for a couple of days following the documentation at
I am using linux computer with Debian Stretch and Python 3.7.3. I created a fork from the repository and cloned the Master. I was able to set up the virtual enviroment and the script/setup ran with out errors.

I ran hass and it has been running now for about 2 hours now,
I have two errors:

  1. ‘could not find known_devices.yaml’, I think this is not an issue.
  2. [homeassistant.componets.updater] Got unexpected response: None,
    Hass appears to be stuck here as nothing has happend for 50 mins now.

I have one warning:

  1. Connected to hue as but not registered. I think this is not an issue


  1. Python 3.7.3 is now supported, correct?
  2. How long should Hass run the first time? Is 2 hours too long, is it hung up?
  3. How can I fix the 2nd error no reponse from component.updater?

It was not clear to me that when I ran hass from the command line that I needed to go the browser to log in at to complete installation. I am not sure if I missed this or maybe it should have been obvious but it appears my install is working.