Trouble setting up letsencrypt add-on, where to find /var/log/letsencrypt?

Have been running hassio on a ubuntu VM (Virtualbox on OSX) locally for a few weeks, and now want to setup letsencrypt in order to have ssl.

I added the letsencrypt addon and set it up, but cannot get a certificate, this is the error that is shown in the addon log:

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator standalone, Installer None
An unexpected error occurred:
ConnectionError: HTTPSConnectionPool(host='', port=443): Max retries exceeded with url: /directory (Caused by NewConnectionError('<urllib3.connection.VerifiedHTTPSConnection object at 0x7f75d7891510>: Failed to establish a new connection: [Errno -3] Try again',))
Please see the logfiles in /var/log/letsencrypt for more details.```

So, I want to have a look at the suggested /var/log/letsencrypt, but no clue where those are?

I have checked the /var/log directory on the ubuntu vm, and also been looking for a stopped docker container to check into, but can't find anything.

How can I check /var/log/letsencrypt to see what is going wrong?

I have the same issue today. Yesterday I could get the request out and has issues with DNS so i ended up hitting the hourly limit for letsencrypt. Today I get the same error as above. I dont see anything in the Firewall log or anything in the DNS log. Is it possible that the letsencrypt is not able to get out to the network. I’m running Hassio on Pi 3


can you post the addon settings? It looks to me like you’re trying to use htpps for auth which is no longer supported by letsencrypt. What port forwarding do you have on your router?

“email”: “rudy@xxxxx”,
“domains”: [
“certfile”: “fullchain.pem”,
“keyfile”: “privkey.pem”

It almost seems like i cant get to the internet from my hassio. I have samba ans ssh, how can I troubleshoot this?


I managed to resolve my issue by setting static ip and dns on my hassio using the usb stick method.

This solved my problem, but as far as I understand, it is an issue specific to Ubuntu server 18.04:

You might want to check what it is in your /etc/docker/daemon.json though…