Trouble setting up Sky Connect with Home Assistant Green (multi radio support)

Hello, new install of home assistant green (November 2023). I plugged in Sky Connect assuming it would be a simple installation. It’s not been smooth at all sadly

  • At one point during setup, it I wanted to use Thread as well, I said sure why not.
  • I then tried to actually configure zigbee and it complained about being multiprotocol and created a Repair, after reading various threads I now I’ve restored the default zigbee firmware (I actually don’t care about Thread right now)
  • Right now I want to simply setup zigbee, so I’m following the steps but not had any luck

Finishing with this “failed to connect” error.

Any ideas?

Try using dev/serial/by-id, you’ll find the id under USB in the hardware info (settings → system → hardware)

Thanks for the reply.

Under USB hardware I can see this.

Screenshot 2023-11-15 at 4.02.59 pm

I also have a dedicated button for SkyConnect, but have no clue what these options mean :melting_face:

Screenshot 2023-11-15 at 4.03.39 pm

Seems you are using the correct port, you could replace /dev/ttyUSB0 with the id (dev/serial/by-id/usb-Nabu_ bla bla), but it probably won’t help. Not using SkyConnect myself, so I don’t know :slight_smile:

1 Like

Thanks for the suggestion.

On the Select a Serial Port step, the correct /dev/ttyUSB0 path was auto selected.

On the Radio Type step I selected, EZSP (which I believe is correct, but it would be great if this simply said SkyConnect)

On the Serial Port settings, I used the full path from hardware info /dev/serial/by-id/usb-Nabu_Casa_SkyConnect_v1.0_96b39378b596ed11892dc098a7669f5d-if00-port0

Screenshot 2023-11-15 at 4.18.05 pm

And still got the error “Failed to connect” :slightly_frowning_face:

I have since tried to go System → Hardware → Home Assistant Sky Connect → Remove multi radio support. Since I believe that is causing the issue.

That failed with The ZHA migration did not succeed.

I eventually solved this by going to System → Add Ons → SkyLink experimental and then removing. Tbh as a newish home assistant user I had no idea Add Ons existed. I was then able to reconfigure zigbee as normal.