Trouble Shooting Zigbee2MQTT on a Mac running Debian - Can't connect devices

Hi Folks,

I’m in need of some assistance.

I’ve spent the last week trying to setup a zigbee network that will communicate with HA. I’m not sure where to start to help get an efficient answer so let me share some things and if someone is willing to suggest some things to try please let me know. I don’t quite know enough about these systems to know where to look first. I’ve watched every video/read every article on the setup process and am still stuck. I wonder if there is something about my system setup that I’ve overlooked or a setting needed to enable this for me that is different from all the videos and resources I’ve found.

Current barrier seems to be that devices are not discoverable. I’m using Sonoff devices. I’m trying a temperature sensor and a door sensor.

Hopefully I didn’t just give anyone enough info to access my system :slight_smile:

Thank you in advance!!

My setup:
Mac Studio with UTM + Debian
Followed this:

Home Assistant 2022.7.7
Supervisor 2022.07.0
Frontend 20220707.1 - latest

Sonoff 3.0 zigbee dongle plus
Followed this: HOW TO - Sonoff Zigbee 3.0 Dongle Plus in Home Assistant (Flash, Update, Zigbeemqtt & MQTT Broker) - YouTube
I have reviewed multiple others and they are all a little different.

Mosquitto Broker:


I assume you have clicked “Permit join” in the Z2M interface while you are trying to pair devices with the coordinator? A timer will then start - I think 5 minutes is the default.

Yup, I’m hoping it is something that simple.
Ive tried multiple devices too

How is your coordinator (dongle) connected to your machine.

What Zigbee channel did you use?

What channel does your 2.4 Ghz wifi use?

Zigbee is ridiculously susceptible tointerference from both 2.4Ghz wifi and USB3 HDDs. It’s reccommmend to use USB2 ports and put the dongle on a short USB extension or hub to reduce USB interference and Mahe sure your WiFi is on a non-interfering channel

It is connected via a 4 port USB hub + extension

Zigbee is channel 25

2.4Ghz wifi channel is set to auto so I changed it to 6

Retested with the channel change and changed the USB hub to just a simple extension and one of those things fixed it!

Thanks for the ideas!