Trouble turning on/off Milights

I just received my very first Milights and I’m trying to turn them on/off at a given time, but I can’t get it to work.

Can someone tell me what I’m doing wrong?


  platform: limitlessled
    - host:
      - number: 1
        type: rgbww
        name: slaapkamer


- id: '1533150930055'
  alias: Turn lights off
    at: '21:26:15'
    platform: time
    service: light.turn_off
    entity_id: light.slaapkamer

Nothing obvious.

If you go to the States page in the frontend, do you see light.slaapkamer listed? If so, click on the symbol to the left of it that should look like this:


That should open a “window” for the light. Click on the toggle button. Does that turn on the light? Click it again. Does that turn it off? (Turn the light on, then close that window.)

If all of that works, then find automation.turn_lights_off in the same list and click the box to the left of it. In that window, click on the word TRIGGER at the bottom. (Not the toggle at the top.) Does that turn the light off?

Depending on the answers to those questions we can go from there.

Thanks for your reply, but I found the problem.

The time_zone was set to UTC, instead of CEST.

I suspected that might be the case, but I wanted to cover some other basics first. By the way, you need to make sure both HA and the OS it’s running on are both set to the same (correct) timezone.

Yes, both are now set to the correct timezone.

Thank you for your help!

1 Like