Trouble upgrading from 0.55

After struggeling with getting sun command up and running HA stopped working after a few weeks.
I have been away from HA for a while because I lost interest and I realise i run an old version. Maybe this is why it stoped working? Anyway. Now I can not figure out how to upgrade.

I run:

Blockquote $ sudo systemctl stop [email protected]
$ sudo su -s /bin/bash homeassistant
$ source /srv/homeassistant/bin/activate
$ pip3 install --upgrade homeassistant
$ exit
$ sudo systemctl start [email protected]


after third line I get an error:

Traceback (most recent call last):
File “/srv/homeassistant/lib/python3.5/site-packages/pip/”, line 215, in main
status =, args)
File “/srv/homeassistant/lib/python3.5/site-packages/pip/commands/”, line 307, in run
delete=build_delete) as build_dir:
File “/srv/homeassistant/lib/python3.5/site-packages/pip/utils/”, line 22, in init
name = os.path.realpath(tempfile.mkdtemp(prefix=“pip-build-”))
File “/usr/lib/python3.5/”, line 497, in mkdtemp
prefix, suffix, dir, output_type = _sanitize_params(prefix, suffix, dir)
File “/usr/lib/python3.5/”, line 269, in _sanitize_params
dir = gettempdir()
File “/usr/lib/python3.5/”, line 435, in gettempdir
tempdir = _get_default_tempdir()
File “/usr/lib/python3.5/”, line 370, in _get_default_tempdir
FileNotFoundError: [Errno 2] No usable temporary directory found in [‘/tmp’, ‘/var/tmp’, ‘/usr/tmp’, ‘/home/pi’]


This is getting real frurstrating!

I currently run 0.55.0.

Thank you, kind people!

There are a lot of breaking changes that you need to read through.

the biggest issue that is likely causing your issue is that python 3.5 is no longer supported. you need at least python 3.6.3.

edit: disregard above!

either update your python to the newer version and then upgrade or just start with a fresh installation using the newest image.

you can save your config files and then add them back in after the reinstall. but then you will have to deal with all the potential breaking changes as mentioned above.

python 3.5.3 is still support.

1 Like

yes you’re right. my bad.

i was thinking 3.5 went away. it was 3.4. since i upgraded to 3.6 i mis-remembered.

I decided to reinstall everything. latest version is running… Now I have to figure out the sun automation once again. spent countless hours last time… thank you guys!