Troubles installing HACS

Hi there,

I’m trying to install HACS to a brand new Hassio installation on a Raspberry Pi 2. I have placed the hacs folder inside the custom_components folder of my config and then rebooted HA.

When I then try to add the integration, the dialog just returns to the integrations list, and the following appears in my log file:

2019-12-04 18:03:18 ERROR (MainThread) [aiohttp.server] Error handling request
Traceback (most recent call last):
  File "/usr/local/lib/python3.7/site-packages/aiohttp/", line 418, in start
    resp = await task
  File "/usr/local/lib/python3.7/site-packages/aiohttp/", line 458, in _handle
    resp = await handler(request)
  File "/usr/local/lib/python3.7/site-packages/aiohttp/", line 119, in impl
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/", line 40, in real_ip_middleware
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/", line 73, in ban_middleware
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/", line 136, in auth_middleware
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/", line 122, in handle
    result = await result
  File "/usr/src/homeassistant/homeassistant/components/config/", line 130, in post
    return await super().post(request)
  File "/usr/src/homeassistant/homeassistant/components/http/", line 48, in wrapper
    result = await method(view, request, *args, **kwargs)
  File "/usr/src/homeassistant/homeassistant/helpers/", line 60, in post
    handler, context={"source": config_entries.SOURCE_USER}
  File "/usr/src/homeassistant/homeassistant/", line 66, in async_init
    flow = await self._async_create_flow(handler, context=context, data=data)
  File "/usr/src/homeassistant/homeassistant/", line 638, in _async_create_flow
    await async_process_deps_reqs(self.hass, self._hass_config, integration)
  File "/usr/src/homeassistant/homeassistant/", line 292, in async_process_deps_reqs
    hass, integration.domain, integration.requirements
  File "/usr/src/homeassistant/homeassistant/", line 77, in async_process_requirements
    if pkg_util.is_installed(req):
  File "/usr/src/homeassistant/homeassistant/util/", line 45, in is_installed
    return version(req.project_name) in req
  File "/usr/local/lib/python3.7/site-packages/pkg_resources/", line 3137, in __contains__
    return self.specifier.contains(item, prereleases=True)
  File "/usr/local/lib/python3.7/site-packages/pkg_resources/_vendor/packaging/", line 703, in contains
    item = parse(item)
  File "/usr/local/lib/python3.7/site-packages/pkg_resources/_vendor/packaging/", line 31, in parse
    return Version(version)
  File "/usr/local/lib/python3.7/site-packages/pkg_resources/_vendor/packaging/", line 200, in __init__
    match =
TypeError: expected string or bytes-like object

When I try to set the token via the yaml :

  token: !secret hacs_token

(with hacs_token the value of my github token) Home Assistant just does not boot, with the same error.

I have tried HACS 0.17.3 and 0.16.3, both give the same result. Am I doing something wrong?
I’m running HA 0.102.3 with supervisor 192 and HassOS 2.12



Did you ever get some sort of response? I encountered this thread thru a search as I am having the exact issue.

Hey MisterMister

It seems like Home Assistant dropped support for the Raspberry Pi 2.


No, HA runs nicely on a RbPi 2, support is not dropped.

Follow the instructions here :

Well I tried it before, and found out the image I downloaded earlier was for the RaPi 3. Thus I went back to the website to download the one for the RaPi 2 and found out the download link was gone.

That made me conclude that support was dropped.

Image for HACS ? There is no image for HACS.

If for HA :

Other machine types

  • intel-nuc
  • raspberrypi
  • raspberrypi2
  • raspberrypi3
  • raspberrypi3-64
  • raspberrypi4
  • raspberrypi4-64
  • odroid-c2
  • odroid-cu2
  • odroid-xu
  • orangepi-prime
  • tinker
  • qemuarm
  • qemuarm-64
  • qemux86
  • qemux86-64

Sorry, I got confused :confused:

Anyhow, what I have never been able to get it working again on a RaPi 2. I did got it working on RaPi 4.

Yesterday I reinstalled my test-HA on a RbPi 1 :slight_smile: