Troubleshooting to enable i2c

Hi, I need to get i2c to be enabled and I followed the instructions from Common Tasks - Operating System - Home Assistant using the Terminal.

But I can not get this to work this way. I need to use the Terminal as I use an SSD drive and can not access this directly due to lack of an adapter :frowning:

Anyway, according to the docu it should work also directly in the Terminal, but after the reboot I do not have a /dev/i2c-0 or anything similar.

I do see a device when I run lsmod | grep “i2c → i2c 20480 0”, so it is there, but if it does not show up in /dev, I assume it is still not enabled?

Any help ?

So, someone created a nice Addon which is doing the exact thing needed and it works. Not sure what the addon is doing differently, cause in the logs it shows exactly what i did directly in the terminal, but well, it works.