Troubleshooting Tuya HA problem


I’m struggling with HA a long time.

What happens is (and it’s mostly with Tuya devices) is once or twice a day for almost an hour I cannot use any of my Tuya devices properly. I’d the state was off and I switch it on it will Togolese back to off. Visa versa. If it was on it will toggle to off. Sometimes it will do what I want toggle back to what it was and do no action to the device.

Wall switches don’t respond. And if I manual his a switch on and off it doesn’t update HA.

I use to have this problem with local Tuya so I switched to Tuya online

The problem sometimes also effects Sonoff devices but mostly it’s Tuya

Beyond this I have :

Replaced all the WiFi in my home with ubiquity devices and made sure that the signal is good every where
I have replaced all the network switches
I bought a new pi4 and reset up everything from scratch
If replaced my internet router with a fancy mikrotik

The problem persists after I reboot but sometimes it fixes the issue. As said if I leave it for an hour everything starts working.

I went as far as making all iot devices get a fixed up from the dhcp and when there is a problem I can ping them with out an issue

I have tried much more.

It’s a problem because I need to turn on or off a light and it’s doesn’t work so I go on to the Tuya app and it works fine there and the eWeLink app. So that tells me the lights and devices are fine.

I’ve pulled out my hair and spent many days and hours trying to figure this out.

Can anyone assist me how to figure out what I’m doing wrong? Could it be that I have over 150 devices on my HA and that causes an issue.

Everything else on WiFi works fine I can play online games, I can browse internet, watch Netflix etc.


Hey all,

I’ve had no replies. Maybe I have not written it the best where … here is a simpler version:

  1. Struggling with Tuya Device Behavior: I’ve noticed that my Tuya devices often lose responsiveness or start acting up, going on for nearly an hour each time. They’ll switch states on their own or just ignore my manual commands altogether.

  2. Issues with Wall Switches: The wall switches I have set up are giving me trouble too. They won’t respond, and even when I manually flip them on or off, Home Assistant doesn’t seem to catch on.

  3. Attempted Integration Switch: I’ve tried shifting from the local Tuya integration to the online one, hoping it might fix these issues, but unfortunately, nothing changed.

  4. Network Infrastructure Overhaul: I’ve upgraded all my network gear – we’re talking WiFi devices, switches, and even my internet router. But despite all these changes, the problem’s still here.

  5. Starting from Scratch on a New Pi 4: I even went to the extent of setting everything up anew on a Raspberry Pi 4, but it didn’t make any difference.

  6. Devices Are Connected: I can ping all my IoT devices when these issues happen, and everything else on my WiFi, like gaming or streaming, works just fine.

  7. Temporary Fix with Reboot: Sometimes, rebooting seems to solve the problem, but it’s always short-lived, and soon enough, the issues are back.

  8. Sonoff Devices Also Affected: It’s not just Tuya; my Sonoff devices also act up from time to time, though Tuya devices are the main culprits.

  9. Wondering About Device Overload: I’ve got more than 150 devices connected to my Home Assistant. Could that be overwhelming the system?

  10. No Issues in Native Apps: When I use the Tuya or eWeLink apps directly, everything works as it should, which leads me to think this is a Home Assistant-specific problem.

What might be worth a try is to install esphome on one or two of your tuya/sonoff devices which behave poorly to see if it makes a difference. The native api with local push isn’t prone to fail unlike polling data from random servers in China.