Trust SmartHome/ KlikaanKlikuit ICS-2000 integration

Hi All,

I’m new to HA and playing with it for a few weeks no. I’m really pleased with it. In basic easy to use and lots of information to find to knock yourself out.

The only thing that i’m running into right now is the control of my ICS-2000 control station. Apparently there’s no direct integration available in HA (or HACS).

I read a lot across this community and on the internet about it and there are some ways to work around it, but none of them work for me.
I could use an RF module, but I have also some Somfy/Ikea(zigbee) devices connected to it.
Just for the logics of myself: why would I get all different modules to control all of them when I have one that is working for me: the ICS-2000
I tried Olisto to work as a “negotiator” between HA and the ICS-2000. It works for “switches” but not so wel for dimmable lights and sensors.

I’m realy looking for a direct integration. It must be possible because the Google Home Assistant is working fine in combination with the ICS-2000.

Can you tell me if there are some smart guys out there that can make this integration? Or can you help me on how to find these smart guys (or girls offcourse)?

I’m apparanly not the only one out there waiting for this integration.

Thanks in advance!

3 Likes

Use my forked repo in HACS

1 Like

Hi Jeroen,

I installed your forked rep on my HA on my synology, I can see that HA has succesfully retrieved all the items from the KAKU account, but I can’t control or see tha actual state of the entities.
In fact all entities of the Light-integration say they are read only because the don’t have unique ID.

It’s like there’s no connection to the ICS2000, (tried putting in the mac without the ‘:’ but has the same result

What is going on here?

kind regards
Nick

I’m still receiving the error “Platform error light.ics2000 - Integration ‘ics2000’ not found” when restarting Home Assistant. Can you maybe help me installing the intergration? Or explain how you did it?

Ok so I managed to fix the error myself already, but the next thing I’m getting into is the fact that the config won’t validate. Validating before restarting takes minutes while it’s normally less than a second. Anyone who knows more about this?

I opened the terminal in the docker container and ran the install command:
‘’’
pip install --upgrade git+https://github.com/rdegraafwhizzkit/ics2000-python@master#egg=ics2000
“”

Next i copied the folder custom_components in the home-assistant config folder and added my mac-
address, email & password in the configuration.yaml

After that i restarted the container and I saw all the light’s in the entities. but they all are read only so I can’t control them. But I get no error in the logs…

bummer

Hi Jeroen,

Thanks for your solution!
At first I didn’t get the pip install to work (I’m fairly new to this) but it turns out there was no need.
Did all the rest of the steps and it works!!

All lights were added and I can control them.
That said: all devices are added as lights :slight_smile:

My tests so far:
Kaku lights on/off works
Kaku lights that are dimmable works
Zigbee (IKEA) dimmable lights do not work. Not on/off and not shown as dimmable light.
Somfy screens are working. Up/down. Cannot stop them half way. Don’t know if HA support that feature…
Switches are shown as lights. Didn’t test it yet to change or read them
Sensors (motion sensor) are shown as lights. Didn’t test it yet to change or read them

So many thanks so far! If you have any ideas in expanding the options, please let me know!

Hi,

I’m currently working on implementing this custom component. But I can’t get the Somfy screens to work. The screen is shown as a light but turning it on or off doesn’t have a effect. Can you help me?

Kind regards

1 Like

Hi Sushi, was there any update on this, I am also looking to get the Somfy screen to work, preferably with the “My button”

Hi Ruben,

how did you fix this error? I am facing the same, HA read the entries from the KaKu account, but everything is in read only.

Silly question most likely but how do you “open the terminal in the docker container” exactly?

Well, I’ve read through the readme file but for the life of me I cannot figure out how to do what is asked :frowning:
If anyone is able to assist, that would be greatly appreciated.

Hi!

I have deployed the ics2000 integration, and my lights are running fine. But my zigbee and somfy devices are not working… Is there any development in this api?

Hi Sushi,

I have the same problem, kaku is working fine for the lights but all my sensors and switches are shown as: light.
Did you ever got a solution for this?

sudo docker exec containerid pip install --upgrade git+https://github.com/rdegraafwhizzkit/ics2000-python@master#egg=ics2000

You have to replace containerid with the right value from:
sudo docker ps

Does this works for the ICS 1000 as well?

Thanks.

I set it up, and this is my error message.

Setup failed for ‘Light’: Integration not found.

What did i do wrong, I followed all the steps.

Thanks.

This is what i get after installing it, whats wrong?

2024-02-14 13:35:05.361 WARNING (SyncWorker_4) [homeassistant.loader] We found a custom integration ics2000 which has not been tested by Home Assistant. This component might cause stability problems, be sure to disable it if you experience issues with Home Assistant

2024-02-14 13:35:11.103 ERROR (MainThread) [homeassistant.setup] Setup failed for ‘Light’: Integration not found.

hi, i’m getting the following error in my log:

Error while setting up ics2000 platform for light
Traceback (most recent call last):
File “/usr/src/homeassistant/homeassistant/helpers/entity_platform.py”, line 344, in _async_setup_platform
await asyncio.shield(task)
File “/usr/local/lib/python3.12/concurrent/futures/thread.py”, line 58, in run
result = self.fn(*self.args, **self.kwargs)
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
File “/config/custom_components/ics2000/light.py”, line 55, in setup_platform
hub = Hub(
^^^^
File “/usr/local/lib/python3.12/site-packages/ics2000/Core.py”, line 38, in init
self.pull_devices()
File “/usr/local/lib/python3.12/site-packages/ics2000/Core.py”, line 70, in pull_devices
decrypted = json.loads(decrypt(device[“data”], self.aes))
~~~~~~^^^^^^^^
TypeError: string indices must be integers, not ‘str’

what can i do about it?