Try HA without Hardware

Which devices can be controlled over a network (tcp/udp/http). I want try HA without z-wave or 433MHz devices.
i do experiment with weather- OK
mediaplayer----- Samsung Smart Tv UE55f8005ST Only can off and can change volume/mute. can’t on with HA
Devicetrackers —doesn’t worked (Installed owntracks on android)

unable to create groups

The component guide is a good reference. There are a lot of components that don’t depend on Zwave. Look through the list and see if you have any of the devices supported. I have some Hues and Milights, I enjoy the integration with my alarm panel via the Envisalink component.

Also - for groups, post your YAML and we’ll see if we can help you out. If you’ve done something wrong, there’ll be an error in home-assistant.log pointing you to the issue.

1 Like

Thanks a lot :slight_smile:

I been stuck here --Samsung smart tv can just turn off and can adjust the sound level can not turn on, and can not any more and Onkyo home theater can turn on and off.
I’ll buy pi3 and Aeon Labs Z-Stick Gen5 USB adapter if I manage to get a little more on HomeAssistan, yet I have install HA on QNAP NAS container station.

# Name of the location where Home Assistant is running
  name: Hjem
  # Location required to calculate the time the sun rises and sets
  latitude: xx.xxxx
  longitude: xx.xxxx
  # Impacts weather/sunrise data (altitude above sea level in meters)
  elevation: 145
  # metric for Metric, imperial for Imperial
  unit_system: metric
  # Pick yours from here:

# Show links to resources in log and frontend

# Enables the frontend

# Enables configuration UI

  # Uncomment this to add a password (recommended!)
  # api_password: PASSWORD
  # Uncomment this if you are using SSL or running in Docker etc
  # base_url:

# Checks for available updates

# Discover some devices automatically

# Allows you to issue voice commands from the frontend in enabled browsers

# Enables support for tracking state changes over time.

# View all events in a logbook

# Track the sun

# Weather Prediction
sensor one:
 - platform: yr
      - temperature
      - symbol
      - windSpeed
      - pressure
      - windDirection
      - humidity
      - cloudiness
      - highClouds
      - dewpointTemperature

# Text to speech
  - platform: google

group: !include groups.yaml
media_player one:
  - platform: samsungtv
    mac: xx:xx:xx:xx:xx:xx
  - platform: asuswrt
    username: xxxxxxx
  - platform: onkyo
    name: Onkyo receiver
      pc: 'HTPC'

I’m not familiar with how the Samsung TV works. You might want to start a thread specific to that question. Make sure your model is supported.

When posting YAML, use preformatted text

What’s the problem you’re having with groups, specifically? You’ll need to post your groups.yaml for us to spot issues.

@smile If you want to experiment with triggers and groups without buying hardware you can emulate switches by using software switches, such as input_boolean and the other input components. Check the automation component list.

As for your problems:

Yes, my samsung smarttv turns off the network once it’s turned off, so turning it back on over the network is impossible, at least on my TV model.

Once you have a raspberry you can try turning it on over HDMI by sending signals with hdmi-cec, or you could get some hardware that lets you emulate remote IR-remotes.

Devicetrackers —doesn’t worked (Installed owntracks on android)

Owntracks should work, but you need to set up a mqtt broker first, since the embedded mqtt broker is incompatible with owntracks, at least for now.

unable to create groups

Well, can’t help you much with this unless you post this config aswell. Two questions though:

  1. Did you doublecheck the filename?
  2. Is the file in the same location as your config file?

I can turn on my Samsung smart tv with smaung tv component in Hass, but turning it back on i use hdmi-cec. How can i use hdmi-cec with samsung tv component.



CEC Scanner LOG when tv is ON.

starting version 3.2.2
opening a connection to the CEC adapter...
requesting CEC bus information ...
CEC bus information
device #0: TV
active source: yes
vendor:        Samsung
osd string:    TV
CEC version:   1.4
power status:  on
language:      eng
device #1: Recorder 1
active source: no
vendor:        Pulse Eight
osd string:    CECTester
CEC version:   1.4
power status:  on
language:      eng
device #5: Audio
active source: no
vendor:        Onkyo
osd string:    TX-NR636  
CEC version:   1.4
power status:  standby
language:      ???
currently active source: TV (0)
/ line 4:    13 Done                    echo scan
        14 Segmentation fault      (core dumped) | cec-client -s -d 1