Trying to add ble+bluetooth to my Intel Nuc with official HAOS installation

hello crazy people :slight_smile: (I promised I will never get here and here I am 2days&nights later without sleep after installing HA for the first time), i love it!

I am running the official vdxl install for intel nuc, Intel® NUC Kit DCCP847DYE, but all usb dongles that have ble+bluetooth require windows/linux hosts… and i have home assistant os… (i want to use BLE for identifying who is where in the house)… what other options do i have? (i also know about the esp32-vroom32 thing, but i feel there’s too much complexity in getting also an arduino for writing on that esp32… not sure if i understood well) :slight_smile: thank you!

I don’t know what “vdxl install” is, never heard of that, but if it is the official way to install HAos onto the NUC, it already should have support for BLE and BT-dongles. And HAos is Linux based. :slight_smile:

Have you just tried putting your BT dongle into your NUC? :slight_smile:

1 Like

yes i was referring to the official install :slight_smile:
and no, didn’t try the usb dongle because i dont have one yet, i was just reading about everything). but for 10-15$ the price of a bluetooth usb adapter, indeed it’s worth trying it, thanks!!

I’m not up to date with NUCs, but don’t they already have some built in BT? I honestly don’t know! :slight_smile: You might try it.

But to be fair, using a seperate dongle is a recommended way, just to get a better reception. :slight_smile:

EDIT: NUCs should have built-in BT. Have you tried that? :slight_smile:

yup… it doesn’t have bluetooth

Yes, you’re right, no BT… So you need a dongle! :slight_smile:

EDIT: Sorry, a little side tracked from my wife and dog here… :rofl:

If you get a dongle, just order some extension cord with it. The NUCs aren’t known for a “bad” BT connection, but it always helps to bring the dongle as far from the NUC (or other PC/RPi), as you can. I for one use a 50cm extension cord and it reduces the interferences a lot! :slight_smile:

Especially, if you later get some other dongle for Zigbee or Z-Wave.

OS wise you should be good to go, if you take one that runs under Linux. IIRC the used Linux in HAos is a relatively plain “Alpine Linux”.

1 Like

thanks a lot! I got a Trust usb dongle for 7$, no drivers needed, just plug & restart HAOS & and play :slight_smile: and yes I also got the zigbee dongle, so I put both on separate 3 meters usb extension cords. (the only problem now is my soundbar is in the proximity of these, and playing music from my iphone to the soundbar via bluetooth got some interferences… will try some rearrangements to see if that solves the problem)

1 Like

Did you ever get Bluetooth working on the NUC running HassOS?

i add a BT Dongle in the NUC. my HA running on a Ubuntu 20.04
i need a install linux driver, or config? Or running plugin and play?

if i go in HA under integration, search for “Bluetooth”

i have this Error:


No unconfigured Bluetooth adapters found