Trying to get HA working

Okay, I’m a long time Domoticz user looking at whether to change to HA. I have a QNAP device that I want to run this on so I thought I would run it up as a Docker instance. So far so good. What I found was that the version it installs is 0.65 and the current version seems to be something like 0.97.

As I am using the QNAP interface and it can only find this version then I can’t load a newer version of the Container. Instead I accessed the terminal of the container running HA and ran the pip3 upgrade command detailed. It seemed to do an upgrade though nothing on the interface changed and I cannot figure out how to find out what version is actually running. I restarted for good measure but no change.

Crucially I cannot see the HASS.IO option that it sounds like would make setting this thing up much more simple. I currently use quite a bit of LightWave RF equipment and have an Rfx device I want to add to HA. So I have it running, I am just struggling to configure it, especially as with it running you cannot edit the .yaml files :frowning:

In the left side menu click on “developer tools”. The info page lists the version.

Why not?

That won’t upgrade the container. When you restart a Docker container any changes you made inside it are lost.

You can always see the current version on the Home Assistant home page. Just, before you upgrade, take the time to read all the release notes between your installed version, and the current release. Failure to do so may result in it not starting and you getting frustrated. Of course, when you run the config check you’ll get told what the problem is, or at least the first one.

Because to see that menu, you have to use the installer.

Yes you can. However you install Home Assistant doesn’t change how it works.

Thanks I can check that. When I try to save the file I am told it is in use and thus can only change it if I stop the container first.

Hi Tinkerer.

Okay, so is a different install altogether than, I’d not realised that. Just checked out the docker instructions for that and I’m not sure how that is going to work given your first comment. I will give this a try and see what happens. Goal here is just to do a base install of the most up to date version of the software before I start trying to do any configuration. Don’t really want it running on another machine though hence why running on QNAP docker is good for me.

If I have to I can virtualise an ubuntu box and run it on there though. Thanks for the pointers.

Wow. That’s not right. No idea why it would be that way though.

Probably I’ve not got it setup right. I suspect if I ssh in I could edit with nano or something.

Make sure you’re not SSHing into the Docker container and editing files inside it, but files in the volume.

I’m not, I’m accessing via a share.

I have now just setup a VM following all the instructions and tried to run, and still no joy. Nothing appears to run at all in the VM though hassio-supervis is running going to the servers port 8123 just gets me a can’t reach this page.

Clearly getting HA working not on a RaspberryPi is not as easy as it sounds…

You need to give a bit more detail for us to help.

All what instructions? Official? From a blog somewhere? A lot of those last ones are not correct.

How are you trying to access the front end? Which web browser? What url?

Have you tried the IP address (and port 8123) in the web browser?

Hi Tom,

I first tried installing Home Assistant from a Container, worked but I am busy and wanted to use HASSIO to simplify.

I created an Ubuntu 18.04 virtual machine and followed through the instructions on installing hassio here: assuming that would be the best way to get it working. All seemed to be successful. I could not access the system though using the :8123, just not found. I checked for other addresses on the VM etc. yet it still did not work.

There was a Hassio.supervisor something or another running though when I did ps -A. I tried all I could think of to get it going and also did apt-get update and apt-get upgrade just in case. Now that hassio service does not seem to be running at all. My plan is to dump the VM tonight and setup from scratch again see if it works this time. If there are any instructions for this that gurantee working it would be great to see them.

Since starting the journey on HA and HASSIO I have understood that HASSIO is actually a container manager, hence why I stopped trying to run it in a container itself and used an LXC VM instead. HA was up and running quickly, but the container version of it is 0.65. It moans about an upgrade everytime but there is no more modern container found to load. HASSIO is a whole other story though and being the newer way of doing things I thought it would have been the other way around :frowning:

Your problem is that whoever created that VM image, they haven’t updated it since 0.65. As a VM, if you know how they installed it though you can update it yourself (assuming it’s not Docker).

Alternatively, you could install a Debian container, and then install it manually, whether that’s a manual install, or what.

Hi Tom,

That Docker image was the official HomeAssistant one in QNAPs library. I’m now working with a virtual machine and have done everything in the install instructions and yet I still cannot actually get HASSIO to run. Just made another attempt today, having become quite frustrated last week.

All the instructions work perfectly there just does not seem to be any HASSio at the end of it. I’m pretty sure it just isn’t running but nothing gives me any information on HOW to run the system, it all sort of assumes it just works.

You might want to swing over to Discord and the #hassio channel.

Typically it takes 20 minutes (or so) for the web interface to become available.