Trying to get my 3D printer camera feed in my HA dashboard

I have a 3D printer running Klipper/Mainsail with a camera that streams webrtc stream.
I can add the stream via a webpage card, and it works, but only if on the lan. When I disconnected from it, and use say, cell network, I can’t access it because Home Assistant says it’s http.

Klipper doesn’t offer an https option in its software, and I’ve even gone so far as to build a reverse proxy for the printer using nginx. Which while it connects to the 3d printer, the 3d printer refuses to serve data over the reverse proxy. Help would be much appreciated.

can anyone help?

I set up wireguard vpn server. Might be an option for you…

It certainly is, but not what I’m looking for.

Not to familiar with reverse proxies but why not You set up a reverse proxy why not a vpn?

Already tried it, Mainsail didn’t want to display over https

Did you try the Moonraker Integration?

what specifically are you speaking about?

Moonraker is the middleman between klipper and mainsail. If that is what your asking.

But the Moonraker Integration is under HACS add on.

I know what moonraker is. I’ve never heard of a moonraker integration. I’ll check it out.

I figured you would.

Yeah it’s nice I just started using it couldn’t get the camera to work that s how I found you.

But it is working now and it is working great.

Thanks for the tip. I’ll get to checking it out tonight. I’ll let you know how I get along.

Yeah please do. I’m curious if it will fix your problem.

So it works, pretty nicely, but the video isn’t video. It’s like a slideshow. Not even 5 FPS. Know anyway to get a smooth stream? Able to see the stream from WAN, so that’s a step in the right direction.

It’s actually not video at all, just showing an image.

Weird. Mine is working fine. Not sure what to tell you there. I am home on my local. I would switch to wan but my cell service at my house is garbage.

Are you running the latest version of moonraker where the camera was changed to webrtc?

Running v0.8.0-138-gfe120952

Also runnin my camera on mjpeg . Tried switching it to webrtc couldn’t get it work.

Are you running crowsnest?

I am, and webrtc. mjpeg doesn’t work since upgrading to webrtc.

What is the version number of Moonraker are you running?

Also what is your set up? Are you running on a pi?

. Weird how mjpeg doesn’t work for you and webrtc doesn’t work for me.