Trying to get Sonoff RFBridge to control RF light

Hi All

I’m trying to control a light that uses RF Codes.
When I use the remote I can see this in the RFBridge console:

tele/rfbridge/RESULT = {"RfReceived":{"Sync":12360,"Low":450,"High":1220,"Data":"597B04","RfKey":"None"}}

So I tried sending this:

  "topic": "cmnd/rfbridge/RfCode",
  "qos": 1,
  "payload": "#597B04"

via the mqtt.publish. I can see it it sent out, but the light doesn’t react on it.
I guess it could because of the #, but if I don’t enter that it sends out something completely different.
So what am I doing wrong here?

It looks like I can store the codes in the ‘preprogrammed’ slots in bridge, but not send them directly.

Take a look at this post.
I used Strategy 2: Demultiplexer

1 Like

I’ve already set it up for demultiplexing when receiving data, but this is sending data to the light, so it doesn’t really apply to this.

What is it?

As I can tell it, it sends out ‘597’ as a number instead.


Do you have two buttons (on/off) to control this lamp or only one ?

I have several buttons :smiley: But yes, seperate buttons and codes for on and off (this is the light)
Using the stored keys in the rfbridge works very well, but it’s difficult to maintain, eg. if the rfbridge dies, so I would much rather have it all in one place.
The light is very stable in turning on and off etc. much better than the other one I tried.

Wow that’s nice I never though this kind of remote are RF remote.

As there is a lot of buttons on this remote, do the RF bridge fails on reproducing with HA all of them or only certain?

I don’t see any of the codes being transmitted properly if I enter the # code.
I’ve tried building most of the buttons with stored keys, and it works, but again, it’s not optimal to not have it stored in HA instead.
I can also see that some of the buttons like ‘white’ takes quite a long press to be captured by the rfbridge, and that results in two codes being stored in one key. This makes it switch between the two white modes it has stored (one is ‘real’ white, and the other is RGB-white) and then switch back to the original white mode.
This is what I’ve built so far with stored keys.

I suppose you are using tasmota seeing your topics. I’m not a tasmota expert but it seems to have an RF raw mode, did you tested with it?

No, maybe I should have a look at that, I wonder if that will interfere with all the other RF433 stuff I have installed already.

I just bought an equivalent and tested it with OpenMQTTGateway and it is compatible.
All the buttons of the remote control can be reproduced by MQTT.




home/OpenMQTTGateway/commands/MQTTto433 {"value":13183501}

@1technophile Yes I had that one at first, mine was sadly defective and didn’t give any red color, so I replaced it with the one I have now, that also produces real white :slight_smile:
I would imagine you would use the OpenMQTTgateway :grin:
I think I’ll get a new Sonoff Bridge, and make it with ESPHome, as it seems to be faster.

I’m hesitating :wink:

Apart from the firmware debate I’m using an arduino with an ethernet shield and this is far faster than the rfbridge.

Ok, that sounds interesting, so how does that work with RF433?

It is just an arduino UNO with an ethernet shield and OpenMQTTGateway:

The use of an ethernet compared to wifi added to the direct handling of the decoding by the uC (no use of an external uC to decode/encode signals) make a huge difference in term of processing time.

If I had to redo it now I would use an Arduino Mega, but it is working correctly since more than 3 years.

1 Like

Just added a little review here:

1 Like

But there is a 433MHz send/receive module on it, right?

Yes you have them on the link I provided.
It can be an STX882 & SRX882