Trying to NFS mount


I am using:

HassOS 4.11. Is there a way to mount nfs share? I tried this one (message May 15 from JZhass) but it gives me an error:

Logger: homeassistant.components.shell_command
Source: /usr/src/homeassistant/homeassistant/components/shell_command/
Integration: Shell Command (documentation, issues)
First occurred: 6:34:28 PM (2 occurrences)
Last logged: 8:51:07 PM

Error running command: mount /mnt/videovalvonta, return code: 111.

NFS share is working and it has been tested from other computer.

First make sure that /mnt/videovalvonta directory already exists. Then just try the command w/o using HA. I used HA Supervised so I usually just pop open the shell of the homeassistant docker container from Portainer and try my commands that way.

This hack that you quoted works for me in HassIO — I’m not sure how different HassOS is and whether it can accept that ONLY workaround I’ve found.

As an FYI, after I upgrade HassIO, HA comes up in safe-mode because the folder /mnt/mystuff does not exist so the mount command fails. I used Node-RED single click automation that runs a docker exec command to create that folder in the homeassistant container, then restarts the container. This brings everything back to normal — but again it’s only after an upgrade. I’m happy to share that Node-RED flow if somebody is interested but it’s pretty simple. They key is in the fact that my Node-RED is hosted on the Ubuntu host and NOT by HassIO. This is key in having Node-RED with admin privileges and ability to control docker containers with shell commands.

Directory exists and manual mount gives me an error:

I tried again from other pc with linux to mount that share and it went without problem… So this “connection refused” error is interesting…

Just as an FYI, I did allow guest to have FULL ACCESS to that folder. That basically cuts out the user authentication piece. I’m on a QNAP NAS which is sharing this folder NFS.

I have the same problem (and based on the folder name, looks like the same use case also :smiley:). Can’t get it to work. Tried setting chmod 777 on the folder on both computers, if that’s what you meant.