Trying to restore HassOS from VM to Raspberry Pi - not working!

Hi all,
So this might be a couple issues, that I’ve been encountering the last few days.

I recently encountered an issue running my HassOS VM installation on top of Unraid, where the working system suddenly would not boot after a CPU upgrade.

No idea why this is happened, and still trying to figure out why the QCOW2 image suddenly refuses to run. I even tried downloading the latest QCOW2 image, and that also refuses.

So because I kept my backup snapshots, I setup a Raspberry Pi and did a restore of my latest nightly snapshot… But thats been a couple days of craziness.

After restoring the snapshot, and logging in, the log is FILLED with issues and errors.
Most of the issues are centered around:

  • recorder
  • logbook
  • history

Can’t seem to figure out why everything is broken like this.

has anyone any advice?

Have you tried deleting the home-assistant_v2.db file (database file)?

Hey thanks for the suggestion!

I guess great minds think alike, because I thought to try resetting my DB just after posting this.

I use the MariaDB extension, and completely uninstalled it and reinstalled.
That seemed to fix the issue with recorder, logbook and history.

Still experiencing a bunch of other issues, but working through them.


1 Like