Trying to setup DuckDNS, can someone explain how to set up the port forwarding

I have been following this guide, and have made it to the set up port forwarding. I have spectrum internet, and have logged into the router and clicked on the home assistant RPI, and selected port forwarding. I think I’m just confused about what i should be putting where in the form to set up the port forwarding… if i have done it correctly i should be able to go to and it will bring up assistant? I just get a page not found. I have tried entering port 443 and 8123 in different boxes. This is what my port forwarding screen looks like…

Can someone please tell me how to port forward 443 and 80 with this form?

So the internal port is the port for Home Assistant, generally 8123, while the external port is the port you want to use to forward to 8123. You can use 8123 in both or you could use 8123 for internal and something else, say 999 if you wanted (bad example), for external. The way port forwarding works:[external port]

Takes you to:

[internal host]:[internal port]

In the example above, if you used 999 then you reach your HA through and if you used the normal port:

To further elucidate using your screen shot:

Custom service name: HomeAssistant
External Host: (leave blank to allow any external host, otherwise only THAT host can use the port)
External Port: 8123
Internal Port: 8123

You could try to set the external host to (replacing ‘mydomain’ with your actual Duck DNS host name) but that might be problematic because you don’t know that Duck forwards from that name, so leaving it blank should allow all.

I hope that makes sense.

So i set it up like you said… if i use i get a “This Site Can’t Be Reached” still, if i use i get the same. I tried entering an external host, it’s looking for an IP and didn’t like the domain address. On the DuckDNS site under Domains what should my current IP be? I entered the one from the log on the add on, is this correct?

Any other sugestions?

I appreciate the help, I’ve been at this for hours and haven’t gotten anywhere.

I’ve sorted it. went a different route. Thanks for the help!