Trying to understand the file structure

According to the AppDaemon instructions: “AppDaemon expects to find a file called secrets.yaml in the configuration directory”

How does that directory relate to the secrets.yaml file that I see on my windows computer network directory seen here:

relate to the secrets.yaml file seen here? :

I am not a linux user, although I have used it in the past. Can I get to the secrets.yaml file found in the first screenshot from the raspberry pi control panel?

yeah you can use the same file.

you then need to use


as your path in appdaemon.yaml
but the file has to have readingrights for the user that you start appdaemon with.

and as for the relation:

you have installed homeassistant in this dir
/home/homeassistant and you probably use samba to view that dir as the same user that runs homeassistant.

you have your configuration from appdaemon in
if you cant view that on your pc then that is because those files are owned by another user and your samba user does not have rights to view that sub dir.

Thank you for this info. This leads to a whole bunch of issues that I am not familiar with. I am using SSH, not Samba. Rather than wasting your time trying to educate me, is there a reference you recommend so I can figure out how to make my files readable? I started using HA because I was impressed by the power, but I am finding the overhead to do anything is overwhelming. I have been trying to get appdaemon to start for over a week and I have read all the docs and watched many utubes, but they all seem to conflict on the tiniest detail, which requires hours and hours of googling, which leads to more rabbit trails. By the way, I have been in programming of all sorts for over 40 years and this thing is bringing me to my knees:(

you have a patient listener here.
so ill try to tell you what you need.

you say you have tried to get appdaemon up and running, so lets make that happen first before we start to think about reusing the secrets file and how we go to the server.
(by the way, i think that the dir you see in windows is from a samba on your linux device and with ssh you create the terminal)

please show me your appdaemon.yaml, tell me what device you have and what you are running (hassio, hasbian, or any other system)
also please share any logs you have telling you that it goes wrong, and how you try to start appdaemon.

untill now there was only 1 person on this forum i couldnt help gettin AD up and running, so i think we will get it to work.

1 Like

and if you like i can also help you at discord in a chat.

You are too kind…

appdaemon.yaml follows:
secrets: /home/homeassistant/secrets.yaml
threads: 10
type: hass
ha_key:!secret home_assistant_password
logfile: STDOUT
errorfile: STDERR
threads: 10

How I start appdaemon: pi@hassbian:/home/homeassistant $ sudo appdaemon -c /home/homeassistant/conf
I have also tried without sudo
pi@hassbian:/home/homeassistant/conf $ appdaemon -c /home/homeassistant/conf ERROR Error loading secrets file: /home/homeassistant/secrets.yaml

I am new to discord too, so I will be fumbling around there:) Here is my credentials jpridemore#1121

the first thing i want to point you to, is how to present code and yaml.
because yaml is not readable this way.
on top on the forum is a link. this one:

but from the error we can see that you have a problem with the secrets file.
so just edit that out and use the secrets file in the same directory as appdaemon.

in the meantime ill try to find you at discord (which i am no expert in too :wink: )

1 Like