Trying to uninstall HACS, for a fresh install

I have been away from HA for over 2 years now. Having just moved, I wanted to be able to load up my HA on my Raspberry Pi 4. However, I noticed my Govee, Alarmo and Wyze custom components that were installed with HACS weren’t working.

It looked as if HACS wasn’t loading properly. So I wanted to delete all my custom components including HACS, and do a fresh install. I’ve tried the following uninstall procedure, as per the writeup:

  • Use the trashbin icon on the integration page.
  • Restart Home Assistant important.
  • Restart Home Assistant (yes, this needs to be done twice) important.
  • Delete the hacs directory under custom_components .
  • Restart Home Assistant.

I can get past the first three steps just fine (although the custom components like alarmo wont let me delete in the integration frontend). Once I get to step 4, I’m getting Errno 39, saying the folder is not empty. It won’t let me delete the HACS folder, or any of the other custom components which are installed with HACS.

I’ve seen something about finding the config/.storage/hacs folder. I have no idea if this is the issue, how to find this, or delete the storage in that folder.

Please forgive me as my knowledge on HA is very limited, and I’ve tried reading and searching. I just need a little guidance as I can’t seem to understand how to rectify this. Thank you.!

I ran into same issue today, the way to delete the hacs directory is via a SAMBA file share browse to the location (not via the file editor, trying to delete using the built-in file editor throws the error you got). Just in case someone else runs into this in the future.

Can you expand on this? I installed HACs through a tutorial and it’s doing the same thing that OP stated for me. I’m also looking to reinstall, but I’m not understanding your instructions.

Do you have Samba share setup? It allows you to view the HA files and folders via file browser/network share. If you’re on Windows it’ll look like this inside File Explorer:

Once you have this setup you can browse and delete hacs “folder” by browsing to:


(XXX.XXX.XXX.XXX is where you’d put in of the IP address of your HA server inside your file explorer, look for a Samba Add-On video on YouTube for more info about setting up Samba and browsing the files on a computer)