Trying to use Home Assistant on second router

i have a Netgear Nighthawk R7000 doing all the work between all my families devices all with all the home automation devices being run by Home Assistant. I have over 60 devices utilizing the router at any givin time and my problem is almost everyday i lose over half of my home automation devices off the router. Meaning the router is not showing them connected but i can use my cell phone with the app for the device and it still works. I think its just too much for the one router to handle between me, my wife and 4 kids that router gets taxed very hard. what im trying to do is dedicate a second router just for home assistant and all the home automation. I have a linksysy wrt1900ac connected through the Netgears lan port and ive switched the linksysy ip addresses to use 192.168.2.??? I havent switched everything over yet im trying to test if i can get it to work first but right now ive only switched 3 wifi bulbs over to the linksys router but i cant get home assistant to find them. The linksys router is connected to the netgear through the lan port then the linksys is connected to the wifi bulb on (these are just example numbers). How do i write the configuration.yaml file where i would normally put the host address as 192.168.1.??? to now look for it on the linksys router. I hope this makes sense thank you

You will need to change all of your HA devices and the HA server to use IP addresses. Have the Linksys router using as its gateway if you want the HA devices to still have internet access.

so then iโ€™ll have to change my duck.dns too?

no, you put a port forward in the Netgear to forward the HA port (8123) to 8123 of IP address The Linksys will then need to have that port forwarded to the IP of your HA server I have a similar setup myself.

oh ok i getcha. that makes sense. Thank you very much iโ€™ll try and switch everything over when everyone sleeping. heaven forbid i interrupt the internet for anything haha thanks again iโ€™ll let you know if it worked out right

I;ve gotten everything switched over mostly. after lots of trial and error ive gotten everything working except my tp link light bulbs. On the app on my phone i can control them no problem. on HA if i have them turned off on the app, HA shows them as unavailable. If if turn them on HA shows them but as โ€œoffโ€. If i try and turn them on through HA it sends the command but then turns off instantly but the lights dont actually do anything. Nothing shows up in the logs. I have another tp link Light switch that i havent switched over yet and HA throws the error cant read state but it doesnt do that with the lights like it thinks its connected to them and all is fine but its not. Any help would be so great Thank you

do you have fixed IP addresses assigned to all of your home automation devices? easy to assign a fixed IP to each device based on their MAC addresses, within your router config. (I keep a spreadsheet of devices and their assigned IP addresses because things can be hard to keep track of once you get a lot of devices)

Yes everything I have is a fixed ip. The only thing I did when I switched them over to the new router was go into the config file and switch the old ipโ€™s to the new ones. The only thing I can come up with is a port issue but if I look at the new router log when I try turning one of the lights on it says NTP. Where my cameras will say 80. I googled NTP and it says something about port 123 so I tried opening those and no luck. Iโ€™m a little lost on the NTP thing. lol i have a spreadshhet to of all my devices, i would be so lost without it haha

Also i have a google home mini. a few of them actually and its still on the old router but its able to communicate with the lights no problem

Just to confirm, you have moved all of the fixed IP address assignements from the old router to the new one? (for the HA devies at least if those are all you want to move)

i still have a few other things to move over but i dont want to move those yet till i figure these lights out because the other lights get used frequently and i dont want to lose functionality to them

thats all good, what I meant was that the IP reservations were taken out of the forst router and entered into the second one only.

yes everything has been taken out. i just double checked to make sure and i just watched the log on the old router when i tried turning on a light again and it didnt detect anything happening.

do you also use fixed IP address assignments in your HA config for the devices? or do you use discovery:

no everything is fixed so everything knows exactly where to look and go but i just noticed something weird on the new router.its a linksys wrt1900ac and the 3 lights im having issues with are all under one connection in the network map. Like my laptop has an icon and if i click on it it shows the ip and details then theres an icon for my tablet and so on but the lights are all under one icon and when i click on it all 3 lights are listed with there seperate ips and stuff but the arent indivdual icons like the rest of my devices and theres no option to change that. now im really confused

have you gone into the settings for the lights themselves and changed the IP details correctly, ie: gateway? I know these might seem basic but I cant think of anything else to check to be honest

the app doesnt let you mess with any connection settings except when you first set it up. it just asks what network you want to connect to and the password for it the rest i do throught the router which is just reserve the ip address it connected to. Iโ€™ll redo them here in a bit and do the whole setup process again and see it if it changes how the appear to the router. Yeah im lost at this too. thanks for taking the time and trying to figure it out with me

what globes are they? have you tried going to their IP address in a browser? does that provide further setup options? (mine dont but might be worth a try, I have Yeelights)

they are the tp link hs100. Ive been trying to figure out how these bulbs communicate if maybe its just a port issue. i used the app on my phone connected to the netgear router(old) and turned the light on and off and checked the log to see what it said for traffic but absolutely nothing showed up like no traffic even went through the router. so i did the same thing and looked at the linksys router(new) and it showed this.
Outgoing log
LAN IP address | Destination URL or IP address | Service or port number https https

Just wanted to keep you up to date on this. After update 74.0 the lights started working. No idea what it was stopping them from working till then but everythings functional now