TS0013_ TZ3000_ switches all lights


I have a Tuya 3 gang no neutral light switch (TS0013 _TZ3000_qewo8dlz) connect to zha. When I turn on/off 1 light, it effect all other lights too. Are there any solution for this, thank you.


Same issue here.
I tried some quirks i found for the ts001x family but non seems to solve the issue.
Any insights from anyone?

1 Like

Found the problem and fixed it by adding a few missing details in the ts001x.py quirk.

A PR is open and should resolve the issue once merged to master and released.

For a quick resolution the quirk could be added manually by adding a custom quirk and using this file:

1 Like

Hi @avid
I have the same problem with a different module TS0003 _TZ3000_odzoiovu

I tried to do some changes in the quirk but didn’t succeed

Do you know what actually fixed it?

More information is here [BUG] TS0003 lights effect each other · Issue #1981 · zigpy/zha-device-handlers · GitHub

Thanks in advance!


Without understanding all we do, we manage to get i work by adding a custom quirk on another project, only with final users contributions:

hope it helps in any way, and if it ends with clean resolution on zhaquirks package, thanks in advance :slight_smile:

I got the same issue.
I tried to use Tuya_magic from Zha_Toolkit. Works great for me

mdeweerd/zha-toolkit: :toolbox: Zigbee Home Assistant Toolkit - service for “rare” Zigbee operations using ZHA on Home Assistant (github.com)

1 Like

Problem occured here too after I installed the switch 3 weeks ago, but removing the device, and reinstalling it just now fixed the issue.

Hi amiraizat124

i have the same problem with this
I don’t quite understand what to do with that ZHA toolkit. Would you be able to help
I have the same device as you

Had the same issue, installed zha-toolkit via hacks and conf file

and then applied this magic spell:

service: zha_toolkit.execute
  command: tuya_magic
  ieee: light.tz3000_qewo8dlz_ts0013_light_X 

And now I’m able to control each device separately

I have the same problem, please tell me:- Where do I apply this magic spell? (do I cut and paste your code at the bottom of the config/configuration.yaml file?)
I have been scouring the web for this information and all I get is the standard “Simply do X,Y and Z” with no full (and by this I mean basic) guide as to how to actually do it. Your help would be appreciated.

I did according to what was said
My enviroment is ZHa on home assistant using Zigbee conbee 2

Teh tuya model is TS00013
I tried ZHA tool kit installed it
And then added this magic spell in configration.yaml

No effect

also then individually i added the lights entity

no effect

Please do help

Same problem for me, I have remove and re-add the device and all works fine now.
ha 2023.8.2

for those who is new to this like me and stumble upon this issue and want a step by step instruction.
after 2 day of head banging, here is the step

  1. install HACS (homeassistant community store) Download | HACS
  2. add integration ZHA Toolkit in HACS GitHub - mdeweerd/zha-toolkit: 🧰 Zigbee Home Assistant Toolkit - service for "rare" Zigbee operations using ZHA on Home Assistant
  3. enable ZHA Toolkit in configuration.yaml
  4. go to Developer Tools on your side panel → Services
  5. Select zha_toolkit.execute as Service
  6. Select tuya_magic as Command name
  7. check Device reference and select your device
  8. or go to YAML mode and paste asafm’s code above and change ieee: <your device>
  9. call service
  10. my light switch is working correctly at this point
1 Like