TS0601 by _TZE204_yjjdcqsq


I just bought couple of temperature sensors and I’m trying to get these working with my Homeassistant setup. I use Conbee III zigbee stick and when i search Zigbee devices these TS0601 by _TZE204_yjjdcqsq are found but there’s no temperature or anything else data showing up.

Same here. Three bought, one of them is TZE200_yjjdcqsq, other two TZE204_yjjdcqsq. Tried ts0601_sensor.py -quirk but no luck. ZHA in use. Might show some values, but they´re not updating properly, and humidity is way wrong.




Looks like I have exactly same situation here

I also tried with ts0601_sensor.py quirk and only one of sensors is sending data.

Below there’s 433Mhz Telldus sensor data from same location for comparison.

TS0601 humidity 27%, Telldus 81%

I had six Telldus sensors too, but it stopped working this week. Luckily ordered before these zigbee-sensors and they came yesterday.

Unfortunately now these problems… I thought this is so much sold sensor that it should work with home assistant without problems, but I was wrong.

I’m experiencing similar. I’m getting no useful information from these TS0601 by _TZE204_yjjdcqsq sensors I bought on Ali Express.

The odd part is that I bought some TS0601 by _TZE200_yjjdcqsq sensors a few weeks prior (I think from the same vendor?) and they work just fine. They show a quirk of zhaquirks.tuya.ts0601_sensor.TuyaTempHumiditySensorVar04 in case that’s useful. Maybe I can try to force that?

It seems I’m not on the newest code for zha-device-handlers. I’m guessing this change will pick it up. Now I’ve just gotta figure out how to make that update happen.

EDIT: Using that file made it better but I don’t know if I’m getting real readings yet. Going to let it sit a while, and then try to debug it in a more detailed manner.

EDIT 2: It appears that indeed this works. Takes a few minutes to sync and stabilize.

1 Like


This worked fine, it does take some time to get a good reading.

To other novices like me: you can follow this to install a custom quirk.

The full file can be download here.

Even this laitest quirk is not working. Sensor has red light constantly on. Is this normal? Tried to remove and re-add device.

1 Like

All working now, seems about right temp and humidity. Battery percent shows 50% with new batteries. Removing device, new batteries, re-adding, and some minutes waiting fixed this. Big thanks for quirk!!

One of sensors is not updating temps for several hours. It´s located next to fireplace, and is used for automation that lowers TRV target temp when fireplace is hot. Removing and re-installing batteries help, is there anything else I could try?

What have you done to make it work?

Just waited a couple of hours, after that it started to work mostly. I think moisture-reading is way off, because it´s sometimes under 10%. I think it should be around 20% in the winter.

Can someone explain me how to use this file? I am a HA noob.