Tts google not working

Anyone having issues with TTS? I have a bunch of automations that stopped working with TTS… anything happening with Google and HA?

I am not sure if it is related but if you updated home assistant recently you have to resetup google assistant as it connects differently now instructions here.

I updated yesterday from 0.104 to 0.107 and boom google stopped working along with few other things :roll_eyes:. I have spent last 4 hours pulling my hair out trying to follow the new setup as well as jumping back and forward between other things that stopped working. I run out of time again to keep going.

The minis are paired and working, if i call the tts service i can hear the “BEEP” but nothing comes out.

Heres my yaml that used to work before.

entity_id: media_player.nursery_speaker
message: Restarting cameras
service: tts.google_translate_say

I never had to do that process before, it all worked out of the box…

Did this work for you in the end?

Did you figure this out?

Sorry things been crazy with work closing down with the plague at the Perth.

I have not yet got to this issue with mine. Since I updated HA to 0.105+ it messed up a couple of things including Google Assistant.

It was getting out of control trying to pick through the issues so I just installed HA and started again which so far has got rid of all my issues.

Google Assistant on the other hand was not something I was expecting to resolve with a re-install as it requires a new type of setup compared to the old method, hence I left it till last and other day to spend with it. As far as I know there is no youtube walkthrough vids yet which was what I followed last time I setup Google Assistant.

I will create one when I do it. I am estimating it will be within 5-6 days timeframe when I can sneak some more time.

hi mine also stopped working from last update ,no fix found till now …

I’ve been working through on a different thread with this issue and the solution has been worked out by @Tamas.Toth.ebola in this thread.

The official notes for google assistant guide are slightly outdated following the api change around but if you follow @Tamas.Toth.ebola notes you should be good.

1 Like

Also for me I had to re-add Cast as integration to my Home Assistant as speakers had disappeared.

If your speakers are NOT showing as entities in Configuration > Entities, if not Configuration > Integrations > + > Search “Cast” > Your speakers should then show in the popup to add.

Check out 3 solutions to Tts google not working on this thread