TTS not working anymore ..?

Hi, until yesterday my TTS from HA to Google Home and a chromecast audio was working perfectly. Now, not anymore
When I write a text on a cast card and press enter, you can hear from the device the quik jingle and then it does not play the voice.

What can that be?

This is my log

16-12-22 21:05:39 homeassistant.core: Bus:Handling <Event state_changed[L]: old_state=<state media_player.cast_audio=idle; is_volume_muted=False, media_content_id=, supported_media_commands=5053, media_position_updated_at=2016-12-22T21:05:31.366788+01:00, friendly_name=Cast Audio, media_position=0, volume_level=1.0, app_id=CC1AD845, app_name=Default Media Receiver @ 2016-12-22T21:05:31.373762+01:00>, new_state=<state media_player.cast_audio=idle; is_volume_muted=False, media_content_id=, supported_media_commands=5053, media_position_updated_at=2016-12-22T21:05:39.482108+01:00, friendly_name=Cast Audio, media_position=0, volume_level=1.0, app_id=CC1AD845, app_name=Default Media Receiver @ 2016-12-22T21:05:31.373762+01:00>, entity_id=media_player.cast_audio>

and this is the code

  - platform: google
    cache: true
    cache_dir: /tmp/tts
    time_memory: 300
    language: 'it'

and this is under script

      - service: media_player.turn_on
        entity_id: media_player.yamaha_receiver
      - service: media_player.select_source
          entity_id: media_player.yamaha_receiver
          source: AUDIO2
    #  - service: media_player.volume_set
    #    entity_id: media_player.home_group
    #    data:
    #      volume_level: 5
      - service: tts.google_say
        entity_id: media_player.home_group
        #volume_level: '5'
          message: "Ragazzi, e' ora di mangiare"

Also having the same problem with TTS after enabling remote access and letsencrypt encryption. Did anyone figure out how to get this working again?

First post so sorry if this is in the wrong place?

New installation of Homeassistant (Yesterday) and everything was fine. Just setup SSL (letsencrypt) and now have the above issue.

Has this been resolved, or any workaround?

Thanks in advance,


add to http: config in your configuration.yalm if you have SSL installed


make sure to put https:// or it will not work

edit: nevermind, its not working for me either

TTS working fine here with SSL.

What errors are people getting, and what are your configs?


There’s another live thread on this, lets stick to that one…

I think I have found the issue (in my case) but not sure how to get it resolved?

how did you get your TTS to work with SSL? I am still struggling with it, I have it casting to GH.

With base url set correctly http://ipaddress:port and it will work just fine. As soon as I uncomment SSL lines and base url to include https instead of http it doesn’t work. Is this something to do with NAT loop back, been reading on this…thanks in advance.

1 Like

I found the solution on the following link. For me, everything was working fine, until I enabled LetsEncrypt. I was now able to use HTTPS but it broke TTS to my Chromecast Audio the same way you explain. I run a PFSense router and I was able to just enable the NAT Reflect feature in my router and it fixed it. Read this post for the explanation. TTS not working with LetsEncrypt