Tts only saying "hello"

I’ve setup google TTS according to the documentation, to send TTS to a mediaplayer running on another Raspberry. problem is, that it only works if I use message “hello”, othewise it doesn’t. I’ve tried running service directly from the developer tools, I’ve made s script or if I run from the media player widget, it only works with “hello” string. below is the example of my script:

    - service: tts.google_say
      entity_id: media_player.koledar
        message: 'hello'

Can you provide an example of what you tried that didn’t work. I would guess that’s where the problem lies, not with the message being something other than “hello”.

If I open media player (named “koledar”) tile and type “hello” in Text-to-speak box, I hear this word from the speakers. If I type any other word or text, nothing happens. same goes with this script:

    - service: tts.google_say
      entity_id: media_player.koledar
        message: 'hello'

The script works, but if I change the word ‘hello’ to anything else, nothing comes out of the speakers. audio on the raspberry is setup correctly, because I can play MP3 files using this media player

Has anyone else had this problem and fixed it? I too am having the same problem.
I haven’t used Home Assistant in months, but it was working then.

This may be a red herring, but I’ll mention it…
I just re-started my Home Assistant yesterday after replacing my router over Christmas (a mesh network). The Google home assistant and the HASSIO VM (hosted on my PC) are all on the same router. The PC (and by extension, the HASSIO VM) are connected directly to the router.

I can make the assistant say “Hello”, but nothing else.

Here is my JSON for tss.google_say:

I haven’t upgraded my Home Assistant yet. It’s at version 0.82.1

More information from the logs below.
I re-synched the groups through the web interface, and restarted HA. No dice.
I’m having issues using SAMBA (um, I forgot the password), so I cannot look at the code. I think I’ll do a re-install tomorrow of the latest version on my Raspberry Pi, but am still interested in a solution to this issue.

If anyone put any thought into this, Thank you!

File “/usr/local/lib/python3.6/site-packages/gtts_token/”, line 57, in _get_token_key
tkk_expr =".?(TKK=.?;)W.*?", line).group(1)
AttributeError: ‘NoneType’ object has no attribute ‘group’

Add a delay after so that the tts can complete before the automation ends. I say someone is at the side doot, then play a doorbell mp3. I had to add a delay because the automation would end and the tts was cut off while the mp3 played…

- id: door-ding-side
  alias: Side Doorbell Ding
  hide_entity: true
  - platform: state
    entity_id: binary_sensor.side_doorbell
    to: 'on'
      seconds: 3
  - service: tts.google_say
    entity_id: media_player.all_speakers
      message: Someone is at the side door.
      cache: false
  - delay: 00:00:03
  - service: media_player.play_media
      entity_id: media_player.all_speakers
      media_content_id: http://.../Door-chime-sound.mp3
      media_content_type: audio/mp3

I’m afraid I don’t know what was wrong, but I fixed my problem by upgrading Home Assistant to the latest version (which was like 0.8x.x at the time)