TTS Problem using picotts

Hello out there,

I am a pretty newby and amateur using HA, so thank you all for your patience and goodwill!

I activated picoTTS via my configuration.yaml

  - platform: picotts
    language: 'de-DE'
    service_name: picotts_say

This is all that has to be done as it should be already integrated into HA out of the box - right?

But as I tried to use

  - service: tts.picotts_say
      message: Das ist ein Test
      entity_id: media_player.treppenhaus_lautsprecher

I do not hear any speech…

Below you’ll find trace and debug screenshots.

Where am I wrong?

Any help is really appreciated!


Ohne Titel 1

Ohne Titel 2

Have you media_source: enabled in your configuration.yaml?

Also my Pico service call has no line target:

Changed target, still not working working.


What do you exactly mean by


Can you please give an example? I thought media sources are not necessary just for TTS use, do they?

If I remove media_source from my configuration.yaml I get the following error:

websocket_api script: Error executing script. Error for call_service at pos 1: Media Source not loaded

How to set speed of picotts ?

Kindly guide