TTS & Sonos doesn't work

I have this in my configuration.yaml

# Text to speech
  - platform: google_translate
    language: 'it'

My Sonos Play1 works right perfect with Spotify but I can’t use TTS.

If I use tts.google_translate_say
with data:

{“entity_id”: “media_player.sala”, “message”: “ciao” }

from the service page nothing is played.
An mp3 file is created into


I can play it with an mp3 player but I hear nothing from the speaker.
On the UI, in the media_player card, I see the “hdksahihehei43864237628892.mp3” file so, it seems that it tries to play it.

Nothing in the log file.

Any idea?

Same issue here, on which version are you? Feels like it happens with 110

Restored a backup with 109.x and tts worked.

1 Like

Hi! Any idea if it’s working again on 0.111??

HI, @akandor and @boggiano, I’ve installed 0.111 and I’m stilll having the same issue. Have you been able to solve it?? Thanks.

Hi. Yes you need to add your base_url to the tts Setting in the configuration.yaml file

Yes I did: first of all, I had to reach HA from the inside with the FQDN name ( not easy with me, I’m not using any plugin since I use the core version).
Then I add this to my configuration.yaml:

  - platform: google_translate
    language: 'it'
    cache: true
    time_memory: 1000

base_url: was the trick!

1 Like

Thank you both. Problem solved!! :wink: :wink:

Should this be updated to use the new internal/external URL and platform config? Seems this broke for me too when I removed base_url for being deprecated in global config.