Tts with Piper - much too quiet

I have successfully created an automation with Piper tts on a Sonos speaker.

service: tts.speak
  entity_id: tts.piper
  cache: false
  media_player_entity_id: media_player.sonos_kitchen
  message: some message

Unfortunately, the spoken text is too quiet to really understand anything. Is there a way to increase the volume of the voice output? Possibly as a percentage?

Many thanks in advance for any advice!

Yes, you can do this with the custom integration Chime TTS and set the audio_conversion parameter to -af "volume=1.5" which will boost the volume to 150% (or any other value).

Many thanks for the tip. I have installed the integration with HACS and added it to Devices & Services. Where can I set the audio_conversion parameter?

Once you install Chime TTS you should now have a new service available: chime_tts.say - you can learn more about it by reviewing the documentation.

Here’s a basic example:

service: chime_tts.say
  entity_id: media_player.kitchen_speaker
  chime_path: bells
  message: This message will play at 200% of the original volume
  tts_platform: tts.piper
  audio_conversion: "-filter:a volume=2.0"
1 Like

Now I understand! Unfortunately, the music on my Sonos stops before the announcement and doesn’t play again. I’ll probably have to look into the documentation…

I don’t have Sonos devices so I can’t test it, but you can add: announce: true to the service call which might fix the issue.